Blank Page URGENT

Permalink
I cannot access the webpage at all. Everything is blank. The only thing I can access is the dashboard. When I try to customize the theme, the page does not show. It is just blank. I need help immediately.

View Replies:
ScottSandbakken replied on at Permalink Reply
ScottSandbakken
Can you post a link?

What did you change before it stopped working?
UWHC replied on at Permalink Reply
I was just editing a few things then when I hit publish.

http://www.liveunitedhudson.org/Main/...
Cahueya replied on at Permalink Reply
Hm, if you've just been editing something I could image something like the webserver was restarting at that time when you coincidentally edited anything. Ask your provider if anything happened in the logs.

Check if your theme files are in place via FTP, some FTP clients can have strange behaviour and move a file when you wanted to do something else. Check if the index.php is in place and if .htaccess is unchanged if you had it. Did you activate pretty urls?

EDIT:

Ok, so after looking around i think:

1. Your database-connection works (Login page displays, your register settings seem to apply)

2. It must be something more than your theme-folder. I think if it was theme-related, you would see the html output without any styling.

3. I am very sure it is either the .htaccess or the index.php in the root of your folder that is causing this failure.

No idea how this i happening, but first step is resolving the emergency = get the site up. Do you have FTP access to see if those files are in place?
UWHC replied on at Permalink Reply
I do not have FTP access to see those files. How would be able to do that?
Cahueya replied on at Permalink Reply
I see, you are on bluehost.

First step, submit a support ticket. Maybe they can see something that you cannot.

Second step, login to your cPanel Interface and find the FileManager or however the thing that lets you view your file system is called. navigate to the root of your site (should be inside public_html), where there should be all the folders of c5 (/blocks, /concrete, /config...) in this directory, there should be a "index.php" file. is it there?

There should also be a .htaccess file that could be faded grey.

Can you log into your dashboard? If so, go check if pretty urls are activated (system&settings->pretty urls) to make them work, you need a .htaccess with the right content. Have you maybe tried activating PrettyUrls? Could be that bluehost does not allow it.
UWHC replied on at Permalink Reply
I did access the Pretty URLs. It gave me a password. I'm looking through the cPanel File Manager now. I've found the .htaccess file, but not the index.php file. the .ht access file is not shaded grey.
Cahueya replied on at Permalink Reply
Ok, so the "password" that prettyurls gave you is (i suppose), the code that needs to be copy&pasted into the .htaccess file. If it is not grey doesnt matter. Try open it and paste the code into it, if it is not there already.
UWHC replied on at Permalink Reply
The code is already there.
UWHC replied on at Permalink Reply
Nvm. I've found both files, but .htaccess is still not shaded grey.
SheldonB replied on at Permalink Reply
SheldonB
bluehost allows pretty urls

This happened to me the first time installing with simple scripts because it wants to put it in its own folder but doesn't tell the server(bluehost) to point to the new folder
UWHC replied on at Permalink Reply
You have any solutions SheldonB? I would really appreciate the help.
UWHC replied on at Permalink Reply
I've contacted BlueHost and they said that my site is exceeding its PHP limits. It was something in the concrete5 update that has it behaving this way. Is there anyway I can downgrade my webpage to the previous version before this ever happened?
SheldonB replied on at Permalink Reply
SheldonB
unless you updated - then the page went blank I doubt that is the problem.

php limits of the page are usually because you are exceeding your set php memory limit for a page (such as to-many photos or incorrectly compressed files taking to much load time)

you can try to fix this by changing your php.ini file to 128mb

I have had issues with some files being to big and i fixed the problem by changing the page version from the sitemap to an older one that had less stuff on it
UWHC replied on at Permalink Reply
How would I be able to do that?
SheldonB replied on at Permalink Reply
SheldonB
UWHC replied on at Permalink Reply
Thank you for the help with the versions. I will keep that in mind. The PHP Limit is already raised to its maximum of 128MB. Are there any other solutions? Do you think restoring my page from a backup in August would fix the issue?
ScottSandbakken replied on at Permalink Reply
ScottSandbakken
You could try deleting the contents of the [root]/files/cache/ and [root]/files/tmp/ folders. Sometimes that helps with these 'mystery' errors.
UWHC replied on at Permalink Reply
That did not work, but thank you. I still need a solution to this issue.
ScottSandbakken replied on at Permalink Reply
ScottSandbakken
You could look in your database at the Logs table and post the last couple error messages from the logText column.

Normally when I have seen this, it is the result of a misbehaving add-on or an error in the config file.
UWHC replied on at Permalink Reply
The last logs are from August and the site was running perfectly fine between that time and now. They do not show much.
UWHC replied on at Permalink Reply
Here's the last update from the error logs

[28-Jan-2014 12:37:47 America/Denver] PHP Parse error: syntax error, unexpected ''concrete5.6.2.1_updater);?>' (T_ENCAPSED_AND_WHITESPACE) in /home2/liveunit/public_html/Main/config/site.php on line 6
Cahueya replied on at Permalink Reply
Can you also please check your "System&Setting", if Debbuging ist set to "display PHP errors", maybe this will give more info.
Cahueya replied on at Permalink Reply
Can you also please check your "System&Setting", if Debbuging ist set to "display PHP errors", maybe this will give more info.
UWHC replied on at Permalink Reply
I cannot get onto my Dashboard.