Block Error {"aID":"791","arHandle":"Main","cID":"202","error":false,"bID":"798"}

Permalink 2 users found helpful
Hi Team

I get a strange error on my web site, but only every now and again when adding or editing a block.

{"aID":"791","arHandle":"Main","cID":"202","error":false,"bID":"798"}

Appears when I submit a content block if i click back the changes have been saved and the error goes away?


Is this a theme Issue? Have a named somthing wrong on the 'Main' content block?


Thanks For any Help
Carl Lee

carl101lee
View Replies:
gihe replied on at Permalink Reply
I also get this. Just started a few days ago.
carl101lee replied on at Permalink Reply
carl101lee
Hi

I could not find the reason, but with a fresh install of the SQL and new concrete.

I backed up the db and copied the modified files to a new install, this seemed to stop the error for me.

Regards
Carl
transmitter replied on at Permalink Reply
transmitter
Just happened suddenly to me as well. We're moving the site from a staging environment anyway but it freaked out my client. Any insight as to why this happens?
veertype replied on at Permalink Reply
Was there a solution for this? I'm having the same problem.
carl101lee replied on at Permalink Reply
carl101lee
Hi I had this issue again with another install..

I managed to solve it by updating the concrete5 install, and disabling all the cache and manually deleting all the cache files.

Carl
mkly replied on at Permalink Reply
mkly
Interesting to hear that this might be cache related. Is it possible that you updated a block/add-on and then started having this issue?

Best Wishes,
Mike
carl101lee replied on at Permalink Reply
carl101lee
Very possible,

It did just start happening possible after I updated an add-on or changed cache settings, as it was when I went to put the site live. which is when I normal enable full cache.

I was luck as a new concrete5 version was out so i just did the update and manually deleted turned of the cache and it stopped.

I have not seen this error at all after the last 4 or so updates this year.

Carl.
mkly replied on at Permalink Reply
mkly
That's interesting. I have seen this pop up and we've never really figured out why. I wonder if it's something with changing the db schema for the addon. I will put it on my list of things to look into. Appreciate the info.

Best Wishes,
Mike
JohntheFish replied on at Permalink Reply
JohntheFish
Is it the json a return from what should have been an ajax request to save an edit dialog? That for some reason has become a normal page request?

Perhaps an issue where a totally independant script error prevents a link/button or submit being attached on click, so the browser tries to load the buttons tool/action directly.

I say that because I have seen similar when developing/debugging blocks and I have a script error that prevents the associated handler from attaching.

I also suspect there may be a timing issue between attaching ajax handlers and the button getting clicked, perhaps following a failed server-side verification or late delivery of one of many files in a page.

I am by no means certain of any of that. Its just something that happens very rarely when I am developing.
mkly replied on at Permalink Reply
mkly
Indeed. That's a very good point @JohntheFish. Maybe it's something like a view.js or whatever being added in a new version. Thanks.

Best Wishes,
Mike
amrod replied on at Permalink Reply
amrod
after testing a theme that was giving the same errors on all block add and edit,
solution is:
make sure all javascripts are written before
<?php   Loader::element('footer_required'); ?>

This is happening on 5.6 + not on 5.5.
designsforchange replied on at Permalink Reply
designsforchange
Thank you amrod! There were 4 lines of code in my footer element folder below that line and this fixed it. Cheers
rritz replied on at Permalink Reply
rritz
Great!! Main problem solved!
BlueFractals replied on at Permalink Reply
BlueFractals
Just replying to an old post... I also had a similar issue on 5.6.3.4. In my case it was one of the external js scripts that was somehow interfering with the CMS. When I removed it, everything started working again.