Bug? Can't move or delete blocks

Permalink 3 users found helpful
Hi all,
I have seven live installs of Concrete5 and on all C5 websites I'm experiencing problems moving and/or deleting blocks. I have been using Concrete5 for two years now but these problems have only surfaced when I've upgraded to or installed a later version of the CMS..

Five of the sites are running Concrete 5.6.1.2 whereas one is 5.6.0.2 and the last one is 5.5.2.1.

In all cases I'm navigating to the page I wish to edit, clicking on 'Edit' >> 'Edit This Page'. I then click on the block that I wish to move, select 'Move' from the sub-menu then drag and drop to the desired place. When I click on 'Publish My Edits' the block reverts back to it's original position and nothing has been saved. This is the same for all of my C5 websites so it's no coincidence...

Likewise, when I attempt to delete a block I'm experiencing problems. I select the block I wish to delete, select 'delete' from the sub-menu and a notification appears stating "Delete - the block has been removed successfully." However, when I click on 'Publish My Edits and return to the page the 'deleted' block is still there..

Out of the above websites one is my own business/portfolio site and the other six are clients websites. I'm receiving a lot of complaints from disgruntled clients who are unable to edit their sites as needed so any help here would be greatly appreciated.

Thank you in advance

View Replies:
HighContrast replied on at Permalink Reply
Following on from my last post, I have been clearing the cache, deleting old cache files from the /files/cache directory, testing in Firefox, Chrome and IE9 but still nothing.

Does anyone have any ideas?
admin replied on at Permalink Reply
i have the same problem. can't seem to find any help on it.
HighContrast replied on at Permalink Reply
Hi dermmedica,
I still haven't found a solution to this problem yet. If I do find a solution I'll be sure to post it on this thread.

Has anyone else encountered this issue? Again, any help here would be greatly appreciated.
studio108 replied on at Permalink Reply
studio108
I am also having a problem on a site that I am developing. When I try to move a block the position doesn't save and just jumps back where I moved it from. I have noticed that the problem occurred when moving the site onto a live host. When attempting to move a block on the same site but hosted locally with MAMP the block position saves correctly.

I am running the latest 5.6.2.1

Is this a hosting problem or a possible database issue?

The main difference between the local and live hosted site is that the live site has advanced permissions activated.

!! UPDATE !
Switching advanced permissions on to the locally hosted site has replicated the problem. Is this a bug?
biomaj replied on at Permalink Reply
biomaj
Hi,

I've experienced exactly this issue on a site that had a messed up .htaccess and wasn't redirecting itself properly to index.php. There was only the slightest typo in the .htaccess

Am pretty certain the symptoms you're describing are .htaccess related.

Cheers,
Mike
studio108 replied on at Permalink Reply
studio108
Hi Mike,
thank you for your help. I don't currently have a .htaccess file set up on this site. I generally create one at the end of the project when enabling pretty urls etc...

Regards
Luke
admin replied on at Permalink Reply
by george that solved it for me. i had a rewrite rule in my htaccess although i can't recall what it was for:

RewriteEngine on
# index.php to /
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /.*index\.php\ HTTP/
RewriteRule ^(.*)index\.php$ /$1 [R=301,L]

once i removed it, all worked well.

thanks!
studio108 replied on at Permalink Reply
studio108
On reading about Advanced Permissions it is advised to enable them at an early stage or quirky problems like this may occur. Problem is I am not sure at the moment how to solve it.

Luke
HighContrast replied on at Permalink Reply
Ok, I've been working away on this trying to diagnose the problem.

Possible causes I looked into - C5 overrides; javascript clashes; css clashes

I've been working away on a new website for a client. There has been no overrides to the install so far but I'm still getting the same problem.
That rules out overrides.

On my clients new website I removed all JavaScript references that I put in my theme but the problem remained.

I disabled all CSS for the theme - again, the problem persisted.

I then tried out a clean install of C5 - with default theme, no sample content and no new addons. Lo and behold I'm faced with the same problem again which leads me to think that it's almost certainly a hosting issue? Maybe a permissions issue with the server?

To be continued.

Hope this helps.
biomaj replied on at Permalink Reply
biomaj
Hi HighContrast,

I'd certainly investigate the hosting side of things. I've often experienced this same issue when there is a rogue .htaccess file overriding something.

They're also easy to miss if your FTP client isn't set to show hidden files.

It might be worth turning on Pretty URL's just to get the .htaccess file in and working. It might solve your ills from the other side if you know what I mean.

Cheers,
Mike
HighContrast replied on at Permalink Reply
Cheers for the suggestions, biomaj - very much appreciated.

I finally traced the issue down to a few lines in the .htaccess file.

RewriteCond %{THE_REQUEST} \/index\.(php|html)\ HTTP [NC]
RewriteRule (.*)index\.(php|html)$ /$1 [R=301,L]


As far as I remember these lines are required to remove the "/index.php" from the URLs. Does anyone know of a workaround?

Hopefully this thread is helpful to anyone facing the same predicament as I did.
admin replied on at Permalink Reply
Congrats on solving the problem. I've now converted my site to Wordpress and life is so much easier. So many useful free plugins now. Was fun while the insanity lasted. :)
zoinks replied on at Permalink Reply
There is also an experimental plugin for WP that allows you to edit the page in live view rather than the dashboard, which was the primary selling point of C5 for me.