can't get out of maintenance mode! Please help

Permalink
Hello,

I just installed Concrete 5 and immediately put it into maintenance mode (where is says "coming back soon") so the site would be down until it is ready for the public.

BUT...now I can't login to access my Concrete 5 account. I read in another forum post that I should be able to go towww.www.sitename.com/index.php/dashboard... and login, which I've done, but then instead of taking me to the dashboard, it takes me back to the "coming back soon page".

Is this some sort of bug, or is there another way to do this?

Thanks for the help!

Jason

View Replies:
Tony replied on at Permalink Reply
Tony
open the config table in your database, and change or delete the row that says SITE_MAINTENANCE_MODE
jasonschlachter replied on at Permalink Reply
I appreciate the help...

I found this line and removed it. Now when I try to log into concrete on my site, I receive the following error.

mysql error: [-9999: Input Array does not match ?: INSERT INTO SignupRequests(id,ipFrom,date_access) VALUES (] in Execute(, )

Do I need to reinstall Concrete to fix this?

Thanks,
Jason
keeasti replied on at Permalink Reply
keeasti
I am new to C5 and had the same problem. I know this thread is old but I got out of Maintenance mode by changing the SITE_MAINTENANCE_MODE cfValue from 1 to 0 in the config table.
Hope this helps some other newbie.
keeasti replied on at Permalink Reply
keeasti
I am new to C5 and had the same problem. I know this thread is old but I got out of Maintenance mode by changing the SITE_MAINTENANCE_MODE cfValue from 1 to 0 in the config table.
Hope this helps some other newbie.
hurricanes replied on at Permalink Reply
I've tried installing concrete 5 twice (5.4.2.2), putting it in maintenance mode and then I'm locked out as user admin. I tried changing the value of SITE_MAINTENANCE_MODE cfValue from 1 to 0 in the Config table but that made no difference. When I originally logged in as admin, immediately after installing c5, I also enabled pretty URLs and changed the password for the admin user. Could either of these made a difference?

I go to <siteURL>/login, enter admin and admin's password and I'm just thrown right back to <siteURL>. Any ideas how to fix this please?
mkly replied on at Permalink Reply
mkly
have you tried going to

http://www.example.com/index.php/dashboard


If you can't get in there you can disable pretty urls by changing the field in the "Config" database table
URL_REWRITING to 0
and then opening up the .htaccess file at the root of your site and removing the part
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>
# -- concrete5 urls end --


if that doesn't work could you post the error or page you get when attempting that?
hurricanes replied on at Permalink Reply
Hi mkly,
Thanks very much. Yes, by going to <siteUrl>/dashboard I was able to get into the dashboard, disable maintenance mode, and then see the site as normal. Phew!

However, I do actually want to use maintenance mode so that the general public can't see my website until it's ready. But every time I enable maintenance mode I end up in the same situation as before - I'm unable to login as admin! Why isn't the maintenance mode working properly? Is it something to do with pretty URLs (which I still have enabled) or is this a bug?
mkly replied on at Permalink Reply
mkly
Do you want to edit site and view all the pages but have everyone else only see maintenance mode? I'm not sure, but I believe maintenance mode will only allow logged in users to see the dashboard not the from of the site.

That said, it wouldn't be too hard to write a quick addon that could do that.
hurricanes replied on at Permalink Reply
Ok, maybe I'm misunderstanding the purpose of maintenance mode. I thought the whole point of it was so the admin (and ideally selected other users) could develop the site in privacy and then disable maintenance mode once they're ready to share it with the rest of the world. If it's only to allow access to the dashboard then I guess it's working as designed.

If you do know how I could 'hide' my site until it's ready to go live I'd much appreciate it please. I suppose I could create a new group, add the people I want to that group, and then set the permissions on the home page downwards to be accessible to that group alone. Seems a bit clunky though.
mkly replied on at Permalink Reply
mkly
You could set the permissions to not allow "guests".
hurricanes replied on at Permalink Reply
Good idea - I might try that. Before I saw your reply I used cPanel to password protect the public_html directory and that seems to work fine for now. Many thanks for all your help.
mkly replied on at Permalink Reply 1 Attachment
mkly
So I ran with the idea we were just talking about and made a quick package addon to solve this problem.

This should allow you to show users the 'maintenance mode' page while still being able to edit and view the pages.

I've submitted it to the marketplace but if you feel like testing it out I've attached it to this post.

NOTE: You should turn off the Concrete5 built in maintenance mode to use this one.

Best Regards,
Mike

ps. If you need a hand manually installing an addon let me know.
hurricanes replied on at Permalink Reply
Thanks! I removed the cPanel password protection and then installed your add-on by unzipping it and uploading into the packages directory. Then I went to the Add Functionality part of the dashboard to install it. Then I went to Dashboard > Maintenance Editor, checked Enable Maintenance Editor? and clicked on Update Settings.

However everyone can see my site. The add-on also doesn't seem to remember the checkbox setting - next time I go into the dashboard it's not checked. Is the setting not being saved? Should I enable Maintenance Mode as well??
mkly replied on at Permalink Reply 1 Attachment
mkly
I'm sorry, I think I gave you one with a silly bug in it. I forgot to change over one of the constants.

You should uninstall the old one and check the box that asks if you want to remove all the files before installing this one.

Let me know if you have any other issues.
hurricanes replied on at Permalink Reply
In case it helps you debug this I couldn't find a cfKey called 'MAINTENANCE_BACKDOOR' in the Config table of the MySQL database. Ah - maybe it's supposed to be MAINTENANCE_EDITOR instead in maintenance_editor/controllers/dashboard/maintenance_editor:
public function view() {
      $this->set('form', Loader::helper('form'));
      $this->set('enabled', Config::get('MAINTENANCE_BACKDOOR'));
   }

and that's why I can't view its setting...
hurricanes replied on at Permalink Reply
You just beat me to it! I have to go now but I'll give it a try later if I have time and let you know...thanks.
mkly replied on at Permalink Reply
mkly
Ya there were a few things I goofed. I renamed it to MAINTENANCE_EDITOR. MAINTENANCE_BACKDOOR was a little silly sounding.

You should delete that table entry as the new one doesn't use it anymore and keeps it package specific.
hurricanes replied on at Permalink Reply
Hmm, sorry, but I'm not sure the new version's working either. When I click on Save Settings I get thrown to <siteURL>/index.php/dashboard/maintenance_editor/save_settings/
Page Not Found
and when I sign out I can see the whole website as usual. When I go into the dashboard again, "Enable Maintenance Editor?" is still not checked.
mkly replied on at Permalink Reply
mkly
hmmm... that's strange. Could you try installing and reinstalling it. Then clearing your cache. It's puzzling that you would get a Page Not Found error of all things. That would mean something like the actual single page is not added. This last one has been tested by a couple people.

By the way, what version of Concrete5 are you running?
hurricanes replied on at Permalink Reply
5.4.2.2. And I've uninstalled and reinstalled your add-on, cleared the cache and I still get the same behaviour as I reported before.
mkly replied on at Permalink Reply 1 Attachment
mkly
Thanks for getting back to me.

Ok so to confirm. When clicking the checkbox it is not persisting after the reload after you click "Update settings"?

Second. Even if you do that users that are _not_ logged in can still access the pages? Or users that do not have edit rights to the particular page? Or both?

If you didn't do this before could you uninstall the package from the dashboard and when you do click the box "Yes, remove the package's directory from of the installation directory."

If you have the ability could you check the database under the config table for MAINTENANCE_EDITOR and MAINTENANCE_BACKDOOR and remove either of those if they are still there. It should still work fine even without this but it wouldn't hurt.

Then use the one attached to this post. Check to see that Concrete5 is seeing the correct version. When you go to install it it should say 1.0.3

Thanks again,
Mike
zacharytluna replied on at Permalink Reply
I am not very good with computers but after a month I finally finished a website when i realized the title online was "my site" I tried entering maintanance mode to fix it but now I cannot log in PLEASE HELP!
LucasAnderson replied on at Permalink Reply
LucasAnderson
Have you tried logging in athttp://www.yoursite.com/index.php/login...

Note: Replace 'www.yoursite.com' with your actual site address.
zacharytluna replied on at Permalink Reply
Just tried it but it says page cannot be found and it has a little home link underneath that > When I click the home link it says Coming Back Soon
This site is currently down for maintenance
zacharytluna replied on at Permalink Reply
Is there anything else that you know of that might work I really appreciate your help
LucasAnderson replied on at Permalink Reply
LucasAnderson
What's the link to your site?
zacharytluna replied on at Permalink Reply
zacharytluna replied on at Permalink Reply
ecogreencarpetcleaning.org
LucasAnderson replied on at Permalink Reply
LucasAnderson
Go here:

http://www.ecogreencarpetcleaning.org/index.php/login...

That gives me a login page. Login. Then if you still get maintenance mode, go here:

http://www.ecogreencarpetcleaning.org/index.php/dashboard...

Then change your System Settings.
zacharytluna replied on at Permalink Reply
You are awsome the second one worked thank your so much. By any chance do you know how to change the site name as it appears online if someone searches my domain name it says "My Site" rather than ecogreencarpetcleaning. I tried chnging site name and clearing cache but this did not work
zacharytluna replied on at Permalink Reply
tommyh replied on at Permalink Reply
tommyh
I had the same issue but resolved it by going to
index.php/login and logining in and within the same browser without closing it go to index.php/dashboard and you can take it out of maintenance mode there.

Good luck!
hurricanes replied on at Permalink Reply
Thanks - I've already got it out of maintenance mode doing something like you said. We're now testing out a new add-on which lets people with edit privileges get access to the website whilst blocking others.
hurricanes replied on at Permalink Reply
When clicking the checkbox it is not persisting after the reload after you click "Update settings"?
- correct.

Even if you do that users that are _not_ logged in can still access the pages?
- correct.
Or users that do not have edit rights to the particular page? Or both?
- I have only 2 users at the moment, both with admin rights. But everyone can see the website anyway.

If you didn't do this before could you uninstall the package from the dashboard and when you do click the box "Yes, remove the package's directory from of the installation directory."
- I have done this every time I uninstalled the add-on.

If you have the ability could you check the database under the config table for MAINTENANCE_EDITOR and MAINTENANCE_BACKDOOR and remove either of those if they are still there.
- MAINTENANCE_EDITOR was in the Config table (vale = 0) and I deleted it. MAINTENANCE_BACKDOOR was not in the table.

Then use the one attached to this post. Check to see that Concrete5 is seeing the correct version. When you go to install it it should say 1.0.3
- it does.

Even after all this I still get the <sitURL>/index.php/dashboard/maintenance_editor/save_settings/ page not found error and the checkbox setting is still not persisted!

Interestingly, I checked the Config table again and the MAINTENANCE_EDITOR entry was missing. For some reason the entry is not getting persisted, although obviously it had been before at some point.

One thing I hadn't said - but just in case it helps - someone advised me to change the permissions for config/site.php from 777 to 600. But that's not relevant is it? I'm pretty sure I did that before installing any of your add-on versions.
hurricanes replied on at Permalink Reply
BTW I'm using Google Chrome 15.0.874.121.
mkly replied on at Permalink Reply
mkly
Don't worry about the Config table anymore. Those were old values that aren't used anymore.

Permissions shouldn't be an issue but thank you for mentioning that. There seems to be an issue with the server passing the value to the controller?

What happens when you go here

http://www.example.com/index.php/dashboard/settings/statistics_save...

replace example.com with your domain. Do you see a box at the top that reads "Statistics tracking preference saved."?

I'm wondering if there is something with pretty urls going on.
hurricanes replied on at Permalink Reply
When I go to that URL I have to sign in as admin and then I end up in the Sitewide Settings page of the dashboard.

I don't see "a box at the top that reads "Statistics tracking preference saved.?", but I do see a box called 'Track Statistics' with a 'Track page view statistics' checkbox enabled.

Pretty URLs are enabled (and have been since I went into the dashboard the first time).
mkly replied on at Permalink Reply
mkly
Could you try going to that address after you have logged in? You should get a blue box that flashes for a second and says "Statistics tracking preference saved."

The address is
http://www.example.com/index.php/dashboard/settings/statistics_saved/


Could you try disabling pretty urls and see if you still get the page not found error when you try the Maintenance Editor form again?
hurricanes replied on at Permalink Reply
Hi. Yes, I see that box which says "Statistics tracking preference saved." now. Sorry - I think I used the wrong URL before.

Disabling pretty URLs didn't stop the 'page not found' error I'm afraid. "The Enable Maintenance Editor?" checkbox is still not persisted.
monofon replied on at Permalink Reply
monofon
I just limit the reading-rights to admin, and that pretty much does the same as closing it for maintenance. But this gives me the possibility to check my progress continuesly.
hurricanes replied on at Permalink Reply
That's nice and simple - thanks! I'll bear that in mind; for now I've just password-protected the site in cpanel.
mkly replied on at Permalink Reply
mkly
If either of you are interested. What we were talking about here is completed and has a bunch more features. It's a free addon in the marketplace now.

http://www.concrete5.org/marketplace/addons/maintenance-editor/...

You can allow access to specific groups now. Also allow for users to register and some other stuff.
hurricanes replied on at Permalink Reply
Thanks; that's good to know. I might give it a try at some point. I really need to concentrate more on putting the actual content in the website for now:).