Can't approve stacks if not logged in as super user.

Permalink
I'm pretty sure that this is only on my end, and not a bug with Concrete5, but I can't seem to allow administrators to approve stack changes. I have tried going into full sitemap, and showing system pages, then allowing all view/publish permissions for administrators for stacks, under Dashboard, but I believe those were already set.
I have also checked the Block and Stack permissions, but those are fine as well.

I don't know where else to check, or what could be causing it, but it would be very nice to fix.

View Replies: View Best Answer
enlil replied on at Permalink Best Answer Reply
enlil
this is assuming you have advanced permissions turned on:

go to dashboard > full sitemap > view system pages > stacks. Click on the stack you'd like administrators to be able to approve, click set permissions. Assign permissions "manually". click ok. click on "approve changes". under included click add, then select, group, administrators and save.

Should do the trick, let me know...

C 5.6.1.2


after further poking around, this DOES seem to be a bit of a deceptive bug. The "approve changes" button you expect to see isn't there, BUT as long as you allow administrators access to view versions an administrator can select and approve the stack version they just created/updated from within the view versions dialogue.
dsw528 replied on at Permalink Reply
Actually, the fix worked perfectly.

I could have sworn I already tried affecting the permissions, but when I checked them, they weren't set correctly. I just set permissions for the "Dashboard" to allow "Approve Changes" and "View Versions" for Administrators.

Thank you for the help!
enlil replied on at Permalink Reply
enlil
No problem. Were you able to get the approve changes button to show up after editing a block within the stack? Or is it as i described, having to still go through the versions dialogue??