Can't edit Page Type "Defaults"

Permalink 1 user found helpful
Hello all!
I've ran into a problem concerning page types.
First of all, Page Types are a tricky subject for me; I'm still learning them.
Basically, ever since about a couple weeks ago, I am not able to edit any of the "defaults" for any page types. I added my own custom page type, and it works fine. It's basically a duplicate of the code in left_sidebar, but I named it with a different handle so I can affect it individually. I first noticed that I couldn't edit the "defaults" in this page type, and I figured it was something I did wrong; since that particular page type isn't very prevalent throughout our site, I just let it be and added the necessary blocks manually. However, now when I go to edit the "defaults" for the "left_sidebar" Page Type, or the "side_main_side" Page Type, or any Page Type for that matter, it does not allow me to edit defaults. I put the Page Type in Edit mode, and there are no editable areas (see attachment). Does anyone know what would cause this, and a way to fix it?
Any assistance would be greatly appreciated.

1 Attachment

View Replies:
dsw528 replied on at Permalink Reply
shlomimir replied on at Permalink Reply
I have the exact same problem. I would be happy to hear some kind of response as well.
mhawke replied on at Permalink Reply
It would be helpful if you attach the actual php file of the page type in question (i.e. left_column.php) Change the extention to .txt so you can post it here and I'll have a look at it.
shlomimir replied on at Permalink Reply
I've found the solution is to manually reset permissions. This is a good work around (i.e. open up page default, hover over edit, click permissions, and grant edit permissions to yourself.)

However, it does not address the underlying problem: why are these permissions being revoked seemingly at random in the first place? At one page types I created had editable defaults, and suddenly this changed. Hope the root can be dealt with.
mhawke replied on at Permalink Reply
Are you logged is as the 'Super Admin' or just an 'Admin'? If I log in as someone from the 'Administators' group, the editable areas don't show up for me to add blocks but if I log in as the Super Admin, then these editable areas show up. Could this be the issue?

Permissions are uber-confusing sometimes so I might be wrong here but aren't the permissions you set on this page type actually setting the permissions that will be used on resultant page once it's used in the site? Theoretically you shouldn't be allowed to alter your own permission settings. Yes/No?
kjdkjd replied on at Permalink Reply
Entered thread via Google,
mhawke's response solved the issue I was having (super user)
Thank you,
CWSpear replied on at Permalink Reply
By manually setting the permissions, I was able to solve my issue. Like you said, there might be a deeper issue, but at this point, it was good to be able to get it working. Thanks shlomimir.

My page was a page type that was installed from the Discussions plugin (the Discussions page type to be precise).
shlomimir replied on at Permalink Reply
Glad to help
jamboray replied on at Permalink Reply
I have two themes in the first theme every thing works fine but at the second theme I cannot click the permission under edit (I use concrete5 5.7).
Even when I drag an item like textbox or image instead of a hand symbol, mous pointer turns to an stop sign.
MrKDilkington replied on at Permalink Reply

Please create a new discussion for this issue.

The current thread is for a different topic and version of concrete5.