Can't Edit Page Type Defaults

Permalink
Hi everyone!
I have posted this topic before, but nobody responded, and I really need help with this.
To get right to the point: I am unable to edit my Page Type "Defaults". When I go to Page Types, I click on Defaults, I put the page in edit mode, and no areas are editable. This has not always been an issue, and I can see blocks that I added from a long time ago, I just can't add any more to any areas (See attach). This is true of my custom page types, and page types that were included in my theme.
Can anyone help me with this?
Any assistance would be greatly appreciated.
Thanks! :)

1 Attachment

View Replies: View Best Answer
Steevb replied on at Permalink Reply
Steevb
Do you have permission?
dsw528 replied on at Permalink Reply
I'm logged in with admin permissions.
Steevb replied on at Permalink Reply
Steevb
'Super Admin'?
So something is different?

You need to check that the theme is not hard coded, meaning it is coming in with no editable areas?
dsw528 replied on at Permalink Reply
I used to be able to edit the page type defaults. All of the editable areas (main, etc..) used to be there. I can't remember how long ago it was, but they just suddenly weren't there anymore.
By the way, what did you mean by 'Super Admin'??
Steevb replied on at Permalink Best Answer Reply
Steevb
What version are you using and have you updated?
'super admin' is main user.
dsw528 replied on at Permalink Reply
Oh, when I logged in as super user, it worked!!
Thank you so much, this could have become a huge problem if it hadn't been solved.
I had no idea you had to be logged in as super user in order to edit page type defaults.
Thank you again!
:)
Steevb replied on at Permalink Reply
Steevb
Good news and sigh of relief!

Glad it's worked out okay

Regards

Steev
joemc replied on at Permalink Reply
joemc
I'm having this same issue. There is only one user, which is the Super Admin, registered to the site. Are there any other reasons why I wouldn't be able to edit Page Type defaults?
joemc replied on at Permalink Reply
joemc
It still works for different themes, but for some reason stopped working for my custom theme... I'll be doing some testing, but I'm not sure what would cause this.
joemc replied on at Permalink Reply
joemc
Nevermind. It ended up being a jQuery error that was killing the Edit bar.