Can't upload files over 2MB using /files/incoming?

I am trying to add some .swf files to my site. I successfully added a couple of 2MB ones, but now I have some 6MB and 7MB ones I need to add.
I gathered that because of PHP limitations I would not be able to upload these files using the Browse... method, so I would have to choose Upload Multiple > Add incoming or Upload Multiple > Add remote files.
However, neither of these methods worked for files over 2MB (they both work for files under 2MB however.)
Here is my PHP info if it helps: .

Thanks in advance,
Edit: sorry, I forgot to mention that when I try to upload the files greater than 2MB, I don't get any error message, just an infinite swirly circle thing.

View Replies:
madeforspace replied on at Permalink Reply
When you are trying to upload a large file you need to do it via FTP into the /files/incoming folder directly to your server.
Once they are in there you can then go to the file manager/upload mutiple/incoming and you should see them in a list there, add them but ticking the check box I think.
Is that the method you are using or did I misunderstand?

Hope that helps
hashtagash replied on at Permalink Reply
That is exactly what I did and I still get infinite swirly circle thing.

Would the PHP memory limit be a problem? I know my (free) host can be a little stingy with PHP limitations.

-- Hash
Mnkras replied on at Permalink Reply
Yes that could be the issue.
hashtagash replied on at Permalink Reply
I have a 64M PHP memory limit. Is that enough?
blokeybloke replied on at Permalink Reply

I don't know if this is relevant to your situation as I am still a newbie.

You mention PHP limitations and 2MB. When I tried to import a large database that was more than 2MB I ran into similar problems. The answer was to change the Maximum Allowed size for Uploaded files line which underneath had upload_max_filesize = 2M (2M is the default I believe)

As soon as I changed this my problems were resolved. This variable is found in the php.ini file, on my server it is in the C:/PHP folder.

Hope this helps, if not, I found the increasing knowledge gained helpful to solve an issue.



P.S There is another variable called post_max_size in the php.ini file which I also change
hashtagash replied on at Permalink Reply
Thanks for you message.
Unfortunately, I don't have access to 'my' php.ini, and I doubt that my web hosting company will change it :-(

I am trying to upload using the incoming directory which I am told can upload these large files without being limited by the settings in php.ini.
If I am wrong about this can someone please correct me.

-- Hash