Check for Updates - is there a way to disable it?

Permalink 1 user found helpful
Every time I login to my site with C5, it does that "checking for updates".

It usually takes about 5 to 10 seconds, but feels a lot longer when I'm waiting.

Is there a way to disable the automatic check and just check manually?

dibbc
View Replies: View Best Answer
mesuva replied on at Permalink Best Answer Reply
mesuva
We might be talking about slightly different things, but I think that's all part of the news overlay you get if you haven't logged in for 24 hours.
I like it for development and our own sites, but I think it will some confuse some clients. So to turn it off, add this line to /config/site.php
define('ENABLE_NEWSFLOW_OVERLAY', false);


All part of the White Labelling support:
http://www.concrete5.org/documentation/how-tos/developers/white-lab...
dibbc replied on at Permalink Reply
dibbc
Yes, that's what I'm talking about. The "checking for updates" and then that box you mentioned that pops up afterwards.
zoinks replied on at Permalink Reply
Is there a way to change or remove the background images. It's a nice look and everything, but not for a cms I want to sell to clients. Why should a CMS have a picture of grass or sky or flowers in the background? No reason I can think of.
weyboat replied on at Permalink Reply
weyboat
Yes you can,
Go to system & settings/interface preferences and make your selection.
zoinks replied on at Permalink Reply
thanks!
mkly replied on at Permalink Reply
mkly
I learned a new word the other day.

Bikeshedding.
weyboat replied on at Permalink Reply
weyboat
Was that aimed at me mkly?
mkly replied on at Permalink Reply
mkly
nononono sorry. heck no. It was about the background image. There have been some epic threads about it.
zoinks replied on at Permalink Reply
Not a big deal, just looks weird. If the welcome screen news portal thing couldn't be turned off and the background image couldn't be deleted, I would probably just say to the client something like, "Yeah, this welcome screen is kinda different and might seem a little distracting, but you can just ignore it, see? (closes window)... But it's a great CMS. Everything you want is up here in this little bar..."
Deladroid replied on at Permalink Reply
Deladroid
I had recently upgraded to 5.6 and all of a sudden my client was complaining that they can't login. I found that it was showing "Checking for updates" for the news overlay, and then nothing would pull up for some reason.

I just used the switch by mesuva to disable it. Blah. Not sure what the deal is.
sherri333 replied on at Permalink Reply
sherri333
Every time I add this code to disable the news overlay, it breaks the site and I get a database error. I am running 5.6.2.1 (due to some conflicts with the newer version of C5, the site is not yet up to 5.6.3.1).

Is there a reason it would break the site to disable the newsflow?
Deladroid replied on at Permalink Reply
Deladroid
Could you paste your config? Sounds like a markup issue.
HopeL replied on at Permalink Reply
HopeL
It would be nice to do this on a per user basis. As webmaster, I want to see the updates but I don't necessarily want the client to have to wait. Any possibility of disabling that in the config?
enlil replied on at Permalink Reply
enlil
I can't speak as to what version first allowed this, but with 5.6.3.1 you can visit Dashboard > Full Sitemap > Options / View System Pages > Dashboard > Customize Dashboard Home. You can edit this page, or change its permissions and properties like any other page!
HopeL replied on at Permalink Reply
HopeL
Hi enlil,

I just checked that and the client's user is not included in the permissions. I will log in as that user tomorrow to see if I get the updates message - hopefully not if all is working!

Thanks so much for your quick response! I love this community!

Hope
HopeL replied on at Permalink Reply
HopeL
Unfortunately, that didn't work. I'll have to deactivate entirely unless someone else has another suggestion. This is in reference to the message that overlays the screen directly after logging in... Trying to get it so I can view it but client cannot.

Thanks.
superwire replied on at Permalink Reply 1 Attachment
superwire
hi - you can do this by going to Sitemap > Dashboard > Options > Show System pages. Then edit the permissions under Dashboard > Welcome to Concrete 5 so the relevant user group cannot view or edit the file.