Composer and advanced permissions

Permalink 2 users found helpful
We are trying to build a community site where users could login and only access the Composer to add new articles to the site.

We have enabled Advanced Permisisons but are struggling to set the permissions correctly.

We have given the user group the permission to access Composer and pages Write and Drafts in the Dashboard.

But when a user open the composer pages, it always opens the Drafts page. The Write page is not accessible even though the settings in Composer, Write and Drafts page are identical.

We have also tried adding the relevant permissions to the page where all the composer pages should be published.

I also tried enabling access to Dashboard. Now I can see the megamenu with Composer, Write and Drafts but cannot access the Write page.

Could anyone offer any help which permission could cause this problem?

View Replies: View Best Answer
eNViSiOn replied on at Permalink Reply
Same problem - did you solve it?
Hypocrite replied on at Permalink Reply
No, we didn't find any solution yet.
keinkoenig replied on at Permalink Best Answer Reply
Had the same problem. Setting permissions for the Drafts folder did the trick for me!

I found detailed instructions on setting up the composer for a user group there:
Hypocrite replied on at Permalink Reply
Thanks, that seems to work. :)
grosik replied on at Permalink Reply
Worked for me too ! thanks.

anyway i was doing simillar solution all the time for my clients and till now i hadn't have problems with permissions.
gmatik replied on at Permalink Reply
This is exactly what i was looking for! Thank you!
LilliMedia replied on at Permalink Reply
You're Awesome! Thanks!
cinq replied on at Permalink Reply 1 Attachment
This seemed to work and now gives my user group access to those composer pages, however, when they go to edit a composer element (that already has sample content) it throws an error and it cannot save. If I set up new, blank content areas it doesn't seem to have a problem. But for some pages, I have sample content formatted as it should appear on the front end that simply needs to be edited with new info.

There is no problem with the super user - just with a managers group that I have assigned, which makes me think it is a permissions problem. Advanced permissions is ON.

The weird part is the error it throws seems to be code from the site. See attached.

Anyone else have issues with this?
OlliSavolainen replied on at Permalink Reply
I found solution for this.
Go to Page Types and "defaults" (currently using Finnish language so maybe right terms...) of that Page Type you want to change. Then change permissions for that type.