CONCRETE5 HORRIBLY SLOW!

Permalink 2 users found helpful
I need help...bad. I have been using C5 for our church website for almost 1 year. It's always been a little slow but now it's horribly slow. It takes over a minute plus to load the home page and sometimes it doesn't load at all. People are beginning to complain that they can't get into our church website athttp://www.riverwood.net.

I contacted our hosting co. (Ipower) and they ran some tests and said all is fine on their end. I am not technical at all and don't know what to do.

Editing is a nightmare. It takes so long (minutes) just to log in then more minutes to edit. Today I logged in (finally) to edit and the edit button isn't doing anything at all. Other problems have been happening over the last few weeks too.

I am at a loss. Visitors to the site need to be able to access our info easy or they will leave. I am very upset and don't know what to do.

View Replies:
wagdi replied on at Permalink Reply
wagdi
You may want to try upgrading to the latest version. I realised mine was noticeably faster after the upgrade.

It also really depends on your hosting package; That may also need an upgrade. I remember someone saying that C5 runs slow on some hosts so another option could be to find a C5 hosting company.
Ekko replied on at Permalink Reply
Ekko
Your hosting company is taking over 30 seconds on average to feed content to the browser. Once content is fed its a 1.3 second load. This is all your host, and you need to contact them with the above info.
globalnerds replied on at Permalink Reply
globalnerds
Who is your hosting provider? If it is godaddy they are notorious for having slow servers. The only way you can get on a better/faster server is to upgrade to their higher (more expensive) plans. If you are on godaddy, I would suggest moving off of them.

I offer hosting that has unlimited bandwidth and the servers are great (I have a few clients who run shopping cart sites without any issues). If you are interested PM me.
rwcomm replied on at Permalink Reply
Our hosting provider is Ipower.
jero replied on at Permalink Reply
jero
Try adding this into your config/site.php

define('CACHE_FRONTEND_OPTIONS', serialize(array('automatic_cleaning_factor' => 0)));


It usually decreases the CPU load by an order of magnitude.
PatrickHeck replied on at Permalink Reply
PatrickHeck
Hi jero,
thanks for this! Can you explain a little what it does?
Best
Patrick
jero replied on at Permalink Reply
jero
I'd love too, but minds immeasurably superior to mine do it so much better:

http://andrewembler.com/posts/improving-the-performance-of-zend-cac...
mkly replied on at Permalink Reply
mkly
I keeps Zend Cache for automatically removing stale or old cache entries. You should run a nightly/weekly/monthly(depending on the site) job to flush the cache. You can just call Cache::flush() but that clears all records. To just grab the old ones you can do
class CleanOldCache extends Job {
  public function run() {
    $cache = Cache::getLibrary();
    // We enable the cache even if it's
    // disabled to clear it
    $cache->setOption('caching', true);
    // We use OLD instead of ALL to only clear old ones
    $cache->clean(Zend_Cache::CLEANING_MODE_OLD);
    // And then disable it again if it was
    // previously disabled
    if(!ENABLE_CACHE) {
      Cache::disableCache();
    }
    return 'Old cache records cleared';
  }


EDIT: To anyone who see this post. This code is wrong. It doesn't actually clean old entries afaik.
julehti replied on at Permalink Reply
julehti
Thank you very much for this hint (and also for Andrew for the original advice)! I added this line to site.php and every page began to fly instead of crawling.

Maybe this hint should be included better in Concrete5's documentation? I guess there are many site builders, who are desperately seeking the solution for the slowness of Concrete5.
medicimedicine replied on at Permalink Reply
OMG. I can never thank you enough for this. I literally can't fathom how this one line of code has changed the speed of my site from absolute unbearable crawling to almost instant load... WHY DOESN'T C5 tell us about this???!!!

Thank you!!
lavapen replied on at Permalink Reply
lavapen
Thanks Jero. Sie wouldn't load (hosted at Godaddy), now it does after that line of code! Still sow, but at least it's there...http://ussdsananselmo.com
growlrooed replied on at Permalink Reply
growlrooed
Does this work for CC5.7.4.2? I notice that that too is a CPU hog.
rwcomm replied on at Permalink Reply
Thank you all very much for your suggestions. I am contacting our host again to see what they can do. Our host is Ipower. Today I have received more input of people frustrations on the extremely slow load times. We are a church and need to have this problem resolved. I am at a loss and very frustrated myself.

Does anyone have a recommendation on the best host provider for C5 sites? Would it matter if we moved? Ipower said this morning they are looking into the slow issue and will let me know when they figure it out. Unfortunately, we don't have the luxury of time. Many people visit our website before attending the church.
s2d replied on at Permalink Reply
s2d
This looks like a hosting issue to me as well. Go tohttp://tools.pingdom.com and run a load time test on your site. That will clearly display the amount of time it takes the host to begin sending the data.

As for good hosting providers, there are several out there. One that I can personally vouch for as a good place to run C5 is HostGator.
mkly replied on at Permalink Reply
mkly
I'm guessing this occurred after you installed a block.

If you have an rss/twitter/anything feed block remove or disable it and check again. I wouldn't be surprised if it was trying to get a feed somewhere and wasn't getting a response and timing out.
pvernaglia replied on at Permalink Reply
pvernaglia
Your Time to First Byte is really high, that's usually an issue on the hosting side and not the concrete side. Sometime shared hosting starts out working great, but as the server you are on starts getting used by more and more people performance suffers. The only way I have found to fix this problem is moving to a better hosting company. I have had good luck with both hostgator.com and bluehost.com
rwcomm replied on at Permalink Reply
We've tried several of the suggestions and nothing worked. Has anyone heard of or used Arvixe hosting? Their reviews are good and we're thinking of switching over to them. We currently have Ipower that seems to be unreliable. Thanks for your comments.
BertOlton replied on at Permalink Reply
BertOlton
In your initial post you mention that concrete5 has "...always been a little slow". While I agree that it sounds like a hosting problem, you might also want to check with your Internet Service Provider. If the host turns out to be the problem, I'll just put in a second plug for bluehost.com. Their live, on the phone support is phenomenal.
frz replied on at Permalink Reply
frz
arvixe does a fantastic job with providing support. You can find them at the top of our hostin page here:
http://concrete5.org/hosting
gmurillo replied on at Permalink Reply
Hi frz,
I thinking to migrate to arvixe. They offers the option to install site with concrete 5.7 presintalled. In my actual host, I have my site with concrete 5.6.
Is there some problem when I migrate my site in 5.6 to the new site with concrete 5.7 preinstalled? In this case, wich is best strategy to do the migration?
Thanks for help,
StefSmeers replied on at Permalink Reply
StefSmeers
First of all, you are off topic.
Secondly, this topic is from 2012.

Just make a new topic about this question and you are more likely to get response from people who know what to do.

To everyone: Don't dig up old topics from over 3 years...
growlrooed replied on at Permalink Reply
growlrooed
Sorry,
I've just been driving myself crazy to find a solution to what's going on with 5.7 and thought maybe this might be of value as a possible one.
M578M replied on at Permalink Reply
you can run a test with:http://gtmetrix.com/
then ad this code to the httacess file to enable gzip:


<Files ~ "^[^\.]+$">
ForceType application/x-httpd-php
SetOutputFilter DEFLATE
</Files>

<FilesMatch "\.(js|css|html|htm|php|xml)$">
SetOutputFilter DEFLATE
</FilesMatch>


for more info go to:
http://webmasters.stackexchange.com/questions/18182/enable-gzip-com...
carmijo replied on at Permalink Reply
Jero, i added that snippet of code to the site.php file and it made the homepage load 3 times faster. thank you.