Contact Form Not Sending Email

Permalink
Hi there,

i've seen a few people with issues like this and have read all the previous relevant threads and tested a few solutions but with no luck: I have a simple contact form on my site which sends ok and give the proper message, it logs the submission in the the dashboard perfectly well. However, the email never arrives at my the email address(es).

I checked with my service provider - Fasthosts - and they are happy that php is all working properly on the server(they set up a test sendmailphp page to test things there end).

I've tried a couple of different email addresses but still nothing arrives.

Any help would be much appreciated.

cheers

Stevie

View Replies:
Reo replied on at Permalink Reply
I have the same problem. It worked when I set it up and has changed somehow. The log shows all is fine but the emails never show up in my inbox.
NUL76 replied on at Permalink Reply
NUL76
Checked your Junk mail?

Is your email address right?

Have you turned on the setting to send yourself a notice of the submission?
sourcedesign replied on at Permalink Reply
Yeah done all that and double checked several times.

I have also just tried it out again by adding more email recipients, I do get a delivery of the form to 1 out of 4 addresses now..?

Why would it get through to 1 address and none of the other 3?

The plot thickens...
sniffydog replied on at Permalink Reply
I've encountered the same issue. We're currently on 5.3.3.1 and when we have the form directed to the company email or my gmail account, it fails. Searching the spam folder yields no results either.

However, when it's directed to my personal yahoo email account, the contact form goes through just fine.

If anyone solves this, please share! Thanks!
NUL76 replied on at Permalink Reply
NUL76
I just remembered I had a problem like this before as well...
We run our email via Google Apps. So in our DNS records we're forwarding the mailserver to Google's mailserver, but the domain points to our server. So according to the PHP server it sends an email to the local server, but he actually needs to send it to the Google server. So this could be your problem as well. Which email addresses do get a delivery? The ones with a domain name that isn't located on the server you're working on? (plus the gmail account)
If so, I'm gonna ask my hosting provider how he fixed our problem.
sourcedesign replied on at Permalink Reply
I tried to 2 addresses at my work email which is a different domain to the one the site is hosted on, nothing arrives.

Also one to a btinternet.com address - again, nothing.

Yet it works to my yahoo.co.uk address.
NUL76 replied on at Permalink Reply
NUL76
Which C5 version are you running?

Or is that admin email address correct?! Maybe it won't send the email because of the reverse DNS.

An other option (in case you're using DirectAdmin) try to turn off the setting "Local Mailserver".

Last option I can help you with is to use an external smtp server. Go to your dashboard > sitewide settings > email.
waldenschool replied on at Permalink Reply
Hey, I'm having this exact same problem. What did you do to fix it?
armillward replied on at Permalink Reply
I have had a few issues with forms on Fasthosts but seem to have cracked it for myself.

1. The admin account for the site has to have an email address on that domain. So for example, on the domainhttp://www.mypubs.co.uk i have created an email account for admin as [email protected]

2. I have set the email in the dashboard/sitewide settings/email section to use an external SMTP mail server.

3. I have set the server to smtp.fasthosts.co.uk and used the [email protected] email account and password.

4. As long as the [email protected] is an "advanced mailbox" this seems to work. Advanced mailboxes are allowed to use this smtp mail server.

Note also that the email address have to be a "legitimate" email for it to work so things like [email protected] will not work.

Give it a try in my example above the form on this site is set to send to my corporate email address on a different domain ie [email protected] and works fine.

Hope this helps...