content block save button not working

I just went in to edit a content block and the save button isn't working. I had already entered the text months ago and simply wanted to implement an 'insert link to page' by selecting the the pre-entered words 'email me' and directing them to the contact page. All worked fine in the text editor, but when I press save it won't work. The hover effect works but then nothing happens at all. Save window remains there until I choose some other action.

View Replies:
Deladroid replied on at Permalink Reply
This is happening to me too. Very frustrating.
aplittlecub replied on at Permalink Reply
Has anyone figured this out?

It's happening with me as well, but only on custom theme, not on default themes
lancewash replied on at Permalink Reply
With me is was the z-index on my btn class. I raised it, in my case, from 10 to 1000 and it corrected the problem.
JayCadilak replied on at Permalink Reply
Yes this is happening to me as well, also only on my custom theme. Everything worked well at one point, but something must have changed as I cannot save a block or even add a new one. The dialog box pops up and works fine, but the blue Save/Edit/Add button is unresponsive. Saving works in the Dashboard, but not when editing blocks.

I also removed all jQuery calls from my default.php but to no avail. I have done a fresh, clean install, and before adding any content or addons I install my theme, and try to add a block, but the Add button is unresponsive even then. So it must be a problem with my theme, but as I mentioned it worked fine at one point and now it does not.
ebrongers replied on at Permalink Reply
The initial post may be old, but keeps accurate I quess
It happend to me also.
But after reviewing the code, there was a </div> too many in mij edit.php form on my custom block.

hope this hint helps
jero replied on at Permalink Reply
I have never had this problem, but following an upgrade to Concrete, I ran into it.

The problem now is that turning on the CAPTCHA actually requires you to enter a value. It doesn't actually have to be correct. The trick is to click the preview tab, enter a value and then click save.