eCommerce country lists

Permalink 2 users found helpful
I have noticed in the eCommerce package that when completing the billing info or shipping info that there is a massive list of countries and counties. Is there a way to restrict the list. I want to sell stuff in the UK only.


View Replies:
droomltd replied on at Permalink Reply
Did anyone figure this out?

Just doing my first c5/ecommerce site and this would be very useful
cleverington replied on at Permalink Reply
I did, but forgot to post...sorry.

1. Go to e-commerce in the dashboard
2. Clcik 'settings'
3. Click 'Order Attributes'

If you want to restrict the shipping address....
4. Click 'Address' in the shipping section.
5. Click the radial button for 'selected countries'
6. Click each country you want to ship to.

Done. I have mine so that I will only ship to the UK, therefore that is the only country in the list.
PeeVee replied on at Permalink Reply
I'm a total beginner with concrete5 and also want to restrict the countries that show in the drop down.
I've searched the forum and found a number of suggestions including the one above but none seem to work.
I've reduced the list of countries in the helper folder, set the default from US to AU and the above.
I think I'm missing something very basic - are the steps for changing code documented somewhere?

Thanks in advance.
cleverington replied on at Permalink Reply

you are correct, this is very simple, but it foxed me for ages!

No code altering required.

Goto Dashboard, Ecommerce, Shipping, Flat Shipping

In the section 'Shipping Available to' you can either select all countries, or chose which ones to ship to.


Craig Leverington
[email protected]
PeeVee replied on at Permalink Reply
Hi Craig,
Thank you for your reply.
I did what you suggested but the default country of "United States" still appears.
The steps I performed were:
1. Go to Dashboard\Shipping
2. Select Flat Shipping
3. Select "Selected Countries"
4. Select "Australia"
5. Save
6. Go to Dashboard and clear cache
7. Go back to my site
8. Choose a product and go to checkout
- The default country is still "United States"
I don't know what else to do.
Am I missing something basic?
webporter replied on at Permalink Reply 1 Attachment
cleverington's post above worked for me:

See attached image for a screenshot of the settings changed to make Australia the only and default country.
patchworkfabricator replied on at Permalink Reply
Hi Webporter,
Thanks for the screenshot - it provided the subtle hint I needed. The screen was called "Edit Attribute" as opposed to "Edit Shipping Type" (where I had been trying to set the country).

To get to the "Edit Attribute" screen as per your screen shot, you need to perform the following steps:

1. Go to Dashboard>Orders to display the order search screen
2. In the top right corner, click the little drop-down and select Attributes to display the Order Attributes screen
3. Select Billing Address to display the Edit Attribute screen
4. Select the Address Options of Selected Countries and "Australia" in the list and Default Country "Australia"
5. Save

The trick is to get to the "Edit Attribute" screen, as opposed to the "Edit Shipping Type" screen which seems to ignores any particular country selections.

It all works now!

Thanks again