Emails not sending through the blocks

Permalink
I have my blocks set up to send to my corp email and my gmail and I have tried the regular Forms block and also the ProForms one and both have the same issue no emails get sent. I checked my email settings and used Default PHP Mail function and I get this error:

The following error was found while trying to send the test email:
Unable to send mail. mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()

What do I need to do to get this working??

timstrathman
View Replies:
AndyJ replied on at Permalink Reply
what do the settings in your php.ini show.

If you're going to use Googlemail as an external smtp server you need to use
smtp.gmail.com
username
password
encryption - SSL
port 465
timstrathman replied on at Permalink Reply
timstrathman
We are using our company SMTP settings.. the file shows SMTP = localhost port 25.
AndyJ replied on at Permalink Reply
are you running on a dev server? What kind of server are you running on?
timstrathman replied on at Permalink Reply
timstrathman
It is on a Windows 2008 Server... IIS6 it is set up as our new intranet server. Getting close now using the SMTP settings rather than the Default PHP option but i'm not sure why the default PHP form option wouldn't work when it works on another site we host locally as well.
AndyJ replied on at Permalink Reply
not going to be much help with IIS I'm afraid - the only thing I'd do would be to click the button to start the default smtp site and check the port settings :). As for using Googlemail there is an extra step you need to take where you go to a page when logged into your Gmail account and click a button which in doing so then allows it all to work properly.

problem is - I can't remember which page you have to go to except it is difficult to find and hardly documented. I'll see if I can remind myself. Hopefully someone else with better knowledge / memory might weigh inand help out....
AndyJ replied on at Permalink Reply
remembered. If you are logged into Google just google 'google unlock captcha'
timstrathman replied on at Permalink Reply
timstrathman
Problem is we aren't using google for the smtp... we are using our exchange email
AndyJ replied on at Permalink Reply
ahhh - you mentioned Gmail in your original post - misunderstood.