Embed Coding

Permalink 1 user found helpful
On another site there was an embed button so I could copy and paste the code to have their audio clip played automatically when my home pages is opened but I don't know where to paste the code. I tried simply pasting it to one of the blocks but now I just get a block with a red x.

So, my question is, when I want to paste an embed code, how do I do it?

View Replies: View Best Answer
coleatron replied on at Permalink Best Answer Reply
coleatron
Have you tried the HTML block? Add a new block, and when you have to pick the type of block pick HTML.
cliffsheets replied on at Permalink Reply
That worked perfectly. Is there a reason I couldn't simply add it to an existing block, though?
coleatron replied on at Permalink Reply
coleatron
Do you mean adding HTML coding to a content block with regular text content? Each block can only have one functionality or type of content. Concrete codes a "content" block as text, so HTML coding won't work in it. Its just the way the blocks are designed to work. That way people that don't want to use or see code don't have to.
cliffsheets replied on at Permalink Reply
That was my problem I was trying to add HTML to a Content Block.

Thanks for your help.
clorenz replied on at Permalink Reply
I'm very much a newbie. I am trying to do the same thing. It's a widget and the code is provided. It's

<script type="text/javascript" src="http://cdn.widgetserver.com/syndication/subscriber/InsertWidget.js"></script><script type="text/javascript">if (WIDGETBOX) WIDGETBOX.renderWidget('dae7e0ff-4b71-4507-af6a-61300c1a6047');</script><noscript>Get the <a href="http://www.widgetbox.com/widget/extra-large-news-from-khn-widget">News From KHN Widget (Larger)</a> widget and many other <a href="http://www.widgetbox.com/">great free widgets</a> at <a href="http://www.widgetbox.com">Widgetbox</a>! Not seeing a widget? (<a href="http://support.widgetbox.com/">More info</a>)</noscript>

When I insert this in the html block, nothing happens. It does not appear on the web page. What am I doing wrong?
coleatron replied on at Permalink Reply
coleatron
I'm thinking their may be a problem with your code, not Concrete 5. Give me a minute and I will see if I can figure out the problem with it.
coleatron replied on at Permalink Reply
coleatron
Actually it seems to be working.

I embeded it on a test page on my website.
http://cambridgeyoungliberals.ca/index.php?cID=122...
clorenz replied on at Permalink Reply
OK, I'll try it again and see if it works. Will let you know. Thanks very much!
clorenz replied on at Permalink Reply
Nope. It did not work. Here is what I did:

in edit mode,

click to add a new block
select html block
paste code provided for widget
click update

Nothing appears, but it did add another block with nothing in it.

Thank you for your help.
coleatron replied on at Permalink Reply
coleatron
That's odd that its working for me, but not for you.
Have you tried emptying the cache (both on your computer and on your website)? Try that and then a page refresh.

Also, can you post the link to the webpage you are trying to post it on?
clorenz replied on at Permalink Reply
I emptied both caches, and it did not work. It creates another block without the widget. When I click on the blank block, the html code pops up-just the code and not the widget.

I was trying to insert it on our main page:http://www.tuckeradministrators.com...

Thank you again for your time.
coleatron replied on at Permalink Reply
coleatron
Well I'm not sure then. Seeing as it is working on my test site I can confirm that its not Concrete5 and its not the code. My guess is that its conflicting with some other code on your page. Try adding it to a more basic page just to test if its working.

Good job on the website by the way... it looks great!
clorenz replied on at Permalink Reply
Thanks so much for your time. Can't take credit for the website design, our web designer did it. I'm just the talking head and did the text. He DID do a fantastic job. Can I give him a plug on this discussion board?