Error after server move - Symfony\Component\ClassLoader\MapClassLoader::loadClass(): Failed opening required 'formify/controller.php'

Symfony\Component\ClassLoader\MapClassLoader::loadClass(): Failed opening required 'packages/formify/controller.php' (include_path='/concrete/vendor:.:/opt/alt/php71/usr/share/pear')

My site is dead becasue its trying to find an addon after i moved the sevrer that its doesnt have -

Formify - Which I purscashed installed - didnt do what i wanted so I got refunded.

Now the site wont load or connect because its missing files what where deleted 2 years ago...

No way to remove this crap form the database - So the site is dead _- Or re-buy the addon install - then uninstall and refunsd addon ---

WHAT A WASTE of my time..

DONT BOTHER TO UPDATE - new version 8+ casue nothing but PHP problems and Addon errors. Just rebuild the site from scratch in latest versions as their is nowt but problems..

View Replies:
JohntheFish replied on at Permalink Reply
PHP errors with entities typical of moving a site with the caches and entities proxy enabled.
If you still have the original, switch off all caches. Put the entities into development mode. Clear the cache. Cleanup all debris. Then make a new copy and try again.

I agree that life would be much easier if the core was more robust against such issues.
carl101lee replied on at Permalink Reply
Thanks for quick response.

The cache was disabled and cleared, before moving,
whats more is the addon is not even listed on the adons on the old version as installed or waiting....

So i had forgotton i had even installed it years ago, then uninstalled and refunded.

TBH.. it had 3 pages 5 images and theme file, So i just installed the lastest version ( fixed bugs with php7.1, with file uploads) and have just copied and the text and images over, toke less time then the 2 hours tryign to fix this issue.

BUT i have about 10 old sites I am moving from the old sevrer to the new cloud server runnign php7.1. And some of these are very big, So i do see my self hitting these issues again....

I also found an old post about removing the listing in the block-list form the database - tried this didnt work ever.
carl101lee replied on at Permalink Reply

Just found the Datase Entites section -- Will keep note of that, not really had need of these settings before? Maybe this woudl have solved it, But fresh install is best now anyways.

JohntheFish replied on at Permalink Reply
It is usually possible to hack your way round it by modifying settings on the destination, deleting cache files manually and if necessary editing the database, but doing that requires a bit more expertise.
I learned the hard way because when making a dev clone from a customer's site they usually send me a zip+sql without any such considerations.