Error message: default.php not found

Permalink
I have never tried creating a website before but I have to for a class and I'm having issues. I made my site using the pygmalion theme but when people view my site (kimberlycarrick.com) a blank mint chocolate-chip page theme page comes up. When I go to the site, I see it how I made it, but others do not. If you go to a sub page (kimberlycarrick.com/personal), this error message comes up:

An unexpected error occurred.
File /home/kimberl3/public_html/concrete/themes/theme_pygmalion_konsus/default.php not found. All themes need default.php and view.php files in them. Consult concrete5 documentation on how to create these files.

I looked at the documentation section on concret5 but I honestly don't have a clue what to look for. Can anyone help?

View Replies:
bourbonn replied on at Permalink Reply
bourbonn
Sounds like your theme wasn't installed properly.

Did you install your theme following these instructions?:
http://youtu.be/GV77-8_LLog

It's usually the simplest way to do it.

If you downloaded the theme and installed it manually, it might be a matter of setting your files permissions correctly.
kcsmalls replied on at Permalink Reply
Yes, I installed it that way and then re-installed C5 and did it again. I have figured out that when you go tohttp://www.kimberlycarrick.com it re-directs you tohttp://kimberlycarrick.com where you get a blank C5 page, but if you change the http:// to www. then it takes you to the site. Do you know how I fix this?
bourbonn replied on at Permalink Reply
bourbonn
Then I think mhawke was on the right path: the problem might come from your configuration and some modifications to your .htaccess file (if you have one) might also come in handy.

If you can send us the content of your config.php file (just make sure to remove the lines with your database access username, password and salt), I could make an educated recommendation.

I chose to have my site on a naked domain (i.e. without the www prefix) with version 5.6 so I went through that process recently as well.
mhawke replied on at Permalink Reply
mhawke
Log in to your site and have a look at the 'View Source'. Near the top you should see some JavaScript like this:

<script type="text/javascript">
var CCM_DISPATCHER_FILENAME = '/index.php';
var CCM_CID = 1;
var CCM_EDIT_MODE = false;
var CCM_ARRANGE_MODE = false;
var CCM_IMAGE_PATH = "/concrete/images";
var CCM_TOOLS_PATH = "/index.php/tools/required";
var CCM_BASE_URL = "http://www.kimberlycarrick.com";
var CCM_REL = "";
</script>


What is concrete5 putting in the last 2 variables? Are they different depending on whether you use 'www' or not?

I've never configured a C5 site as a 'naked domain' so I don't know what the ramifications might be to how C5 calculates these costants.

@bourbonn... What are the advantages of configuring the domain in such a 'non-standard' way?
bourbonn replied on at Permalink Reply
bourbonn
Well, in my case it was mostly for aesthetics to be honest. It's my personal website so I experimented a bit. I find myself rarely typing the www. prefix when accessing websites by memory and most domains let me in without judging wise to correct me.

Especially now that Concrete5 doesn't set up BASE_URL by default on new installations (it makes it easier to move website from one location to the other), you can access the site (on my host at least) from both the naked domain and the www standard subdomain. Both are fine but I've read some articles recommending to just pick one for SEO purposes.

I've seen records of issues with some hosts and some services not working on naked domains. I haven't encountered any in my case but that might be what is happening to kcsmalls here.

I'm still picking up a few things as far as SEO is concerned so this might just be extra work for plain url aesthetics.
kcsmalls replied on at Permalink Reply
Thank you guys, I'm not sure what I did, but now it works just fine!
mhawke replied on at Permalink Reply
mhawke
It's possible that the DNS info for your website had not completely propagated out to the www when you were first tried to work with it. How soon after setting up the hosting package were you having your initial problems?
mhawke replied on at Permalink Reply
mhawke
I downloaded and installed the theme and it seems to work well. What's in your [root]/config/site.php ? Make sure you remove your database password before posting it here.
Nelluk replied on at Permalink Reply
Sorry to bump an old thread, but this is the only one I could find that looks similar to my issue.

Brand new C5 installation on 1and1 hosting. Up til this point everything has worked fine. I am trying to fork the "rigidlight" package theme following the instructions in
http://www.concrete5.org/documentation/how-tos/designers/modify-a-p...

I copied the c5/packages/rigidlight/themes/rigidlight folder to
c5/themes/rigidlight_modified and edited the Description.txt inside that folder.

When I reload my Theme Installation page I see a new theme with the Rigidlight icon but a blank Name/Description.

When I click preview I get a message of:

/homepages/30/d310386338/htdocs/cms_c5/concrete/themes/rigidlight_modified/default.php not found.

I have applied permissions 777 to the themes folder and all subfolders. I did need to put an .htaccess file in the root c5 directory to make 1and1 Hosting use PHP5, as per instructions.
jelthure replied on at Permalink Reply
jelthure
is there a "default.php" file located here:
/themes/rigidlight_modified/default.php


if so then is the original package installed?
Nelluk replied on at Permalink Reply
Yes, that file exists.

The original theme is still in the /packages directory, if that is what you mean
jelthure replied on at Permalink Reply
jelthure
is the package for the original theme installed in the dashboard?
Nelluk replied on at Permalink Reply
Yes
cmsdev replied on at Permalink Reply
Hello all,

I had the same error message while developing my own theme:

An unexpected error occurred.
All themes need default.php and view.php files in them. Consult concrete5 documentation on how to create these files.

The problem for me was that default.php had a capital D ie: Default.php. When I changed it to lower case the error message disappeared and the website worked fine.

Hope this helps.
Nelluk replied on at Permalink Reply
Not the case for me, sadly.

I kind of suspect that the problem will be related to the fact that it is installed in a sub-directory?
I have c5 installed in /c5, and then a subdomain set up cms.mysite.com which points to /c5 - is that non-standard?
Nelluk replied on at Permalink Reply
Based on a user's PM, I disabled the Override cache and that seemed to solve the main problem - I can now preview the forked theme accurately.
It still gives me (No Name) (No Description) though, strangely. But, at least I can work on the site now. :)