Fancybox Gallery Lightbox Feature not working

Permalink
http://stadiumnyc.com/c5/concrete5.5.2.1/index.php?cID=127

lightbox popup doesn't work, just takes you to the image on a seperate page!

benvickers
View Replies: View Best Answer
Mainio replied on at Permalink Best Answer Reply
Mainio
Try changing this:
<script src="http://cdn.jquerytools.org/1.1.2/jquery.tools.min.js"></script>


To this:
<script src="http://cdn.jquerytools.org/1.2.7/all/jquery.tools.min.js"></script>


Looks like that old one includes the jQuery library that is already loaded. This might break something but not sure though...
benvickers replied on at Permalink Reply
benvickers
Thanks for the perfect solution. It seems though this is effecting my jquery popup overlay.

It's pushing the popup itself under the exposure. Any idea how i might fix this?

I guess the simplest thing would be to turn off the exposure?
Mainio replied on at Permalink Reply
Mainio
Something with your CSS z-indexes, doesn't even do that with every browser.

You should try fixing that by debugging your elements' CSS z-indexes and see what's wrong. If some element is not applying the z-index, change its position to "relative".
benvickers replied on at Permalink Reply
benvickers
Thanks for you help but the issue still persists, it seems to be directly related to the Fancybox element since on all other pages it works fine.

Tried setting relative also tried setting a lower z-index to exposeMask. Neither of which seems to make a difference! Any help would be much appreciated!
benvickers replied on at Permalink Reply
benvickers
I just removed the expose function, seems simpler fix than anything else!
Mainio replied on at Permalink Reply
Mainio
Ok.

My opinion is that usually if you use some popup-dialog library, you should stick to one and only library and not mess them together. That way you can avoid such problems quite easily.