File sets no longer work

We're running a site on 5.6 and file sets don't seem to work anymore. The sets we previously used are fine-- they still show up and have files in them. But we cannot add any files to new sets or to older sets.

Has anyone experienced this? Any ideas what we can do to get file sets working again?

View Replies: View Best Answer
focus43 replied on at Permalink Reply
Same issue with one of our sites.

See reply below on how our dev fixed it.
hutman replied on at Permalink Reply
What happens when you try to add files to a fileset? Do you see any errors in the javascript console?
CygnetMidwest replied on at Permalink Reply
Looking at it with Dev Tools open, I get this error in the console when I try to add a file to a set:

jquery.js:4 POST net::ERR_EMPTY_RESPONSE

Not sure if this is related to the error (or it is the error) that focus43 mentioned.
focus43 replied on at Permalink Best Answer Reply
Our developer fixed the issue - here is his description of what the problem was and how he fixed it.

"Previously we were running on MySQL 5.5. MySQL was upgraded to 5.6. The FileSetFiles class was passing a null value as the timestamp, which should have told the MySQL server to set the column value to the current timestamp. Instead the server rejects a null value (if you look in chrome's network tab, you'd see a 504 server response with the SQL error being output). Solution was to override the FileSetFiles class and make it set the timestamp property in there via code."
CygnetMidwest replied on at Permalink Reply
Turns out updating to fixed the issue for us. Whew!