Firefox and url links

Permalink
I build and edit my web site in Safari. Some of my visitors who use Firefox say my links are not working. When reviewing in Safari & Explorer they work fine but it is true that the links in Firefox are not working. I got half to work. Its probably operator error but can't seem to determine what is wrong. Here is the link to the page in question. Thanks in advance!

Joe

View Replies:
Steevb replied on at Permalink Reply
Steevb
What Link?
jbrew2 replied on at Permalink Reply
Sorry...here its...http://www.brunettifamily.org/family/index.php/usa-hall-fame-league/current-season/computer-managers/

It looks awfull now as I'm trying to figure out why but you should see the problem clearly in FireFox....no issues with Safari or IE.

Joe
teamdb replied on at Permalink Reply
teamdb
was it ever fixed? what was the issue? I have same problem on my site.
Firefox and Chrome links do not work on IE they do.

aabctexas.us
jbrew2 replied on at Permalink Reply
I tested my web site with FireFox and the url's now work. I think the issue was more how I updated this particular web page than with Concrete5. This page gets updated manually 4 or 5 time a week. To save time, I was copying and pasting the changes. But, what was happening was a large amount of html code (I will have to go back and see what it was) was remaining residing on the web page. When I posted this issue, never really got a reply until your e-mail so, I deleted all the contents and stated over. This mystery code went away and so did my url problem. It might have been a Concrete5 issue or just me. I'll see if I can recrete the error.

Joe