Fixing PHP settings to make site run faster

Permalink 1 user found helpful
Hey everyone, is a real-estate site built using C5. It is running really slow, and I am trying to fix this problem. The hosting provider, Network Solutions suggested the following (see below) Does anyone know how to do this?

I would have your developer look at the php settings in this file. Have him change any settings that need to be changed for the website to work properly. I would recommend upping the memory_limit to 128MB.

Once the changes are made it needs to be saved as php.ini and uploaded to the cgi-bin of the server.

NOTE: The settings in /cgi-bin/php.ini will override all of the settings from the server's php.ini, so all of these settings should be included.  
If the settings adversely effect other people on the server, the settings may be removed or the package may be  suspended.

Server php.ini settings:
session.save_path = /data/tmp
upload_tmp_dir = /data/tmp
asp_tags = On
register_globals = On
safe_mode = Off
upload_max_filesize = 25M
post_max_size = 25M
output_buffering = 1024
mime_magic.magicfile = /usr/share/misc/file/magic.mime
memory_limit = 16M
include_path = .:/usr/services/vux/lib/php
allow_url_include = 0
allow_url_fopen = 0
extension_dir = /usr/services/vux/php5/lib/php/extensions
zend_extension = /usr/services/vux/php5/lib/php/extensions/
zend_extension = /usr/services/vux/php5/lib/php/extensions/

View Replies:
guythomas replied on at Permalink Reply
I think most "slow" running concrete5 sites are due to MySQL database resource traffic jams. Some hosts jam quite a few users onto a single MySQL server causing everyone's websites to slow down significantly when there are a lot of database queries.

First off, make sure you are running the most recent version of concrete5 5.4.1 . This version has new caching features which will reduce the number of queries we need to make on the database.

In order to take advantage of those cache functions go to the dashboard and select the "Sitewide Settings" tab.

In the right column there are two actions you need to take. I see you are already running google analytics so shut off the "Track page view statistics."

Now just below that make sure Basic and Full Page cache are on. If the website doesn't update very often, you may even want to set you own cache lifetime. Crank it way up.

Now visit your site again, which will build the cache. Then visit it again and see if things have sped up.
jwebolution replied on at Permalink Reply
Good advice!