Form Block not working

Permalink
Hi,

After a few months of happily running several c5 sites I have recently come across problems with the form block on two different sites.

1) One c5 site which is hosted on a on-site server seems to not be emailing forms at all. It saved all form entries into the database and can be exported into excel files, etc. But it does not send emails out. I have tried creating new pages with new forms... etc, ... nothing is sending. Is there something i need to be aware of, maybe something not installed properly on the server?

2) Another c5 site which I am running, when sending emails after every form submission, contains the same email address in the "from" section. Wondering how I can change this?

If anyone has any ideas I would appreciate it. Thanks!

Patrick

patmanh
View Replies: View Best Answer
frz replied on at Permalink Best Answer Reply
frz
1) check to see if the site can send mail at all. if you use the forgot password functionality, do you get a message? most likely mail is just not configured to work on the box through php correctly.

also a possibility is that you're sending mail to an address at the same server, and if that domain is setup to have a MX record pointing elsewhere the webserver may not know that it isn't also the mail server.

2) the form block never did this. there's no custom attribute of "email" type for the form, so there's no way the form would know which field is an email vs. which field is a phone number or whatever.
patmanh replied on at Permalink Reply
patmanh
Thanks Franz for your reply.

1) I have checked and the forgotten password utility is not sending emails either. How should I go about re-configuring mail?

2) And perhaps I am confusing you, simply put I would just like to change the "sender" of emails that are sent from the site... currently it just so happens to be my email address. Maybe this is something that can't be changed?

Thanks for all your help.
Mnkras replied on at Permalink Reply
Mnkras
Hey

your server may not have the php sendmail function, you will have to configure a SMTP server you can use google apps if you don't have one but your hoster should.

and for number it can be changed with a bit of hacking in version 5.4 it will be a lot easier
guythomas replied on at Permalink Reply
guythomas
On your second point. The "From" address is the same address associated with the superuser on the account (User ID 0). Change that users email address in the dashboard to change the From address.

-Guy
JonRimmer replied on at Permalink Reply
what do I need to change to get the site to send mail to an email address on the same domain if the mx records are on a different server to the website/

Thanks for your help
FatTony1952 replied on at Permalink Reply
FatTony1952
I'm having the same issue. My client's site was working well with sending emails when a form was filled out, now it won't do it. It has functioned for several months using the php mail server setting, but now it isn't functioning properly.

Any news on what may have happened? They assure me that they haven't changed anything on the forms.
patmanh replied on at Permalink Reply
patmanh
Hi Tony,

As it turns out, the php mail() function was not working on their server. It was a few years ago when we tried to sort it out, but using a combination of phpinfo() and manually testing mail() functions allowed us to see pretty quickly that it wasn't a c5 problem and was a php setup/configuration problem.

I know this isn't the answer you wanted to hear, but I hope this helps!

PH
FatTony1952 replied on at Permalink Reply
FatTony1952
Thanks. I have the client checking their server settings and the php mail() function. I did notice that the mail function worked correctly until they set up a secure certificate on their server. I'm wondering if that is more than a coincidence.

I found on another thread that the default mail to is nobody or 0 and I'm wondering if the secure certificate won't allow the form to sent to 0? That's just off the top of my head and I could be way off base.
FatTony1952 replied on at Permalink Reply
FatTony1952
I've checked the php settings and it doesn't look like anything is different from when we moved the site. I've checked the error logs and the maillog says that the message was 'accepted for delivery' and the stat is Sent. I see nothing in the error_log file other than a File does not exist: /www/html/wpad.dat entry. I'm not sure what that means exactly.

I have no clue what the issue would be other than it may have something to do with the installation of the SSL certificate onto the server possibly?

EDIT: I checked the Messages log on the server and found this:

Jan 12 09:59:21 localhost setroubleshoot: SELinux is preventing the sendmail from using potentially mislabeled files. For complete SELinux messages. run sealert -l 3ce5a......