Google Map

Permalink
Can someone explain why when entering a Map Address we get "Must Enter a valid address"?

This is an address that we have put into Google and Bingmaps, they both find the correct L/L and all is well.

Yet the Block simply will not allow us to enter the address.

At the outset, we were very happy with C5, but the more we dig into it and start using "Built-in" features, they either don't work as promoted OR we get "Invalid pckg id" errors.

This is all with the Elemental theme and "Zero Add-ins".

Someone is going to ask so here is the Map address (try it...):
244173 Range Rd 283 RR 6, Calgary, AB T2M 4L5, Canada

AND L/L: 51.076648, -113.843384

it is most frustrating and C5 V8 seems to be so unstable that I felt compelled to yell and voice our growing annoyance.

The docs are all but useless and outdated, so where to now???

Thanks.

BW

View Replies:
mesuva replied on at Permalink Reply 1 Attachment
mesuva
That particular address doesn't work for me in normal Google Maps.

I removed the 'RR 6' bit in the middle, so the search was '244173 Range Road 283, Calgary, AB T2M 4L5, Canada' - that worked for me.
barbedwire replied on at Permalink Reply
You are correct this map address works when mapping:

244173 Range Road 283, Calgary, AB T2M 4L5, Canada

Unfortunately, that address places the Client office in the wrong geo location. In other words, that address places them almost 1km (.6 miles) west and 1.2km (.75 miles) south of where they are actually at. This puts them in the middle of a small lake. We believe this to be is a map issue, not a C5 issue. The fix is to put the RR6 in the address and the client no longer needs "scuba gear"...

Using other code that we have on other sites (html/js with google embedded api) allows us to use the actual coordinates and everything is actually 99% accurate (i.e., you don't need a boat and the time to designation is correct).

The point of this post is that when adding 244173 Range Road 283, Calgary, AB T2M 4L5, Canada the Google Map Block we get "... Enter a Valid Address...".

That is an issue with C5...

We even tried the "Styled Map" block - same error...

And to add to the annoyance, we deleted the C5 block, cleared cache (which is all OFF), added a new block and it doesn't matter what address we place in the new block, the ORIGINAL address is pulled out of the db. In other words, it seems C5 is not updating the DB with the new Map info.

Again, clearing cache, restarting the web server and the physical server makes no difference. Add a new map on a new empty page will add the new map with the new data and it works fine - with the original location issue of course.

Our work around is to use our own code, but that breaks the cardinal rule of being "C5" consistent.

Just to be clear, this is a virgin site using Elemental with zero add-ins (the test we did with the Styled Map was on a different server).

We spun up a new dummy server last evening in our lab, threw C5 8.1 on it with no add-ins - just plain out of the box Elemental. Same error/issue.

So????