Help! Admin login isn't working

Permalink
I'm trying to log into an installation I've been working on, as recently as yesterday. However, every time I input the user name and password it tells me "Invalid username or password."

Um...not true. I'm also logged onto the database through PHPMyAdmin, and under "Users" I can clearly see the uName, uEmail, and uPassword. A copy and paste eliminates the possibility of typos...and it still won't let me log in.

It also won't email me a new password, even though I tried that as well. What's my next step? Start over?

1db
View Replies:
Mainio replied on at Permalink Reply
Mainio
You can reset the password manually also if you have the access to the database.

Here's a guide on that:
http://www.concrete5.org/documentation/how-tos/developers/i-cant-lo...

Antti / Mainio
1db replied on at Permalink Reply
1db
Thanks. I reset my password on the database, and it did nothing. But the link you posted allowed me to look at the Logs table and retrieve the URL for the password reset link, so I'm in now.
Mainio replied on at Permalink Reply
Mainio
Great!

In the manual reset you should be really careful that you have:
a) the right password salt from config/site.php
b) exactly the right password in the update command
c) the password and salt in the update command wrapped in the MD5-function (something like uPassword = MD5('your_new_password:PASSWORD_SALT'), PASSWORD_SALT being your site's password salt

With manual updates you really need to check that you haven't missed even one letter there and don't have e.g. extra spaces etc in the update command. It SHOULD work fine after you've done everything as the guide tells.

But great that you got it solved! Just said that if you need this also in the future.


Antti
gailsedotes replied on at Permalink Reply
Reset password via email works BUT every time I log out it forgets my password! every single time.

Not a happy bunny.
weyboat replied on at Permalink Reply
weyboat
Try clearing the concrete cache AND your browser cache (remove any cookies that reference your login)
gailsedotes replied on at Permalink Reply
been there done that. and logged in via clean alt browseres

what seems to have temporaily worked is once in - going to Dashboard > Members > "me" > reset password

it hasnt kicked me yet but not too optimistic...
no news will mean this worked