Help! Can no longer edit pages - the edit bar just disappears and logs me out.

A client just called me as he is trying to change a photo on his site and can't get the page into edit mode. I've tried myself and this is what happens:

When I log in I go to the homepage and the edit toolbar is showing, but when I click "edit this page" then the toolbar disappears and I am logged out. The same thing happens if I try to go to a different page.

If I click on the other features from the toolbar, such as "properties" or "design", it says "Access Denied" in the popup.

I have also tried visiting the page I wish to edit from the sitemap in the dashboard. When I do this I get the "Editing" message in the toolbar, and the button to "exit edit mode", but the page itself doesn't actually appear editable - there are none of the usual outlines, clickable elements etc - the page just looks flat and normal.

In the user settings I was not added to any groups, so I added myself to the administrators group and tried again. No change. My client is in the "authors" group.

I was running version 5.6.1 but have updated to and it made no difference.

Can anyone help please?!

View Replies:
edbeeny replied on at Permalink Reply
I have seen this when there is an issue with JavaScript in the theme. What is your url and I will have a quick look.
LauraHogarth replied on at Permalink Reply
edbeeny replied on at Permalink Reply

Had a quick look and can't see any obvious issues. Does it happen on every page? Is there any issues in the logs?
LauraHogarth replied on at Permalink Reply
Hi, sorry - I didn't get an email notification of your reply for some reason!

It happens on every page. I keep getting logged out when I try to go to any new page (or the dashboard) and have to log in again.

The only thing I can see in the logs is as follows:
Page "Members" at path "/members" deleted

...but there is nothing like that on my personal site which I have discovered is having the exact same issues.

I have 2 other client sites using Concrete5 and neither of them are having problems, so I wonder if it could be something to do with the hosting? Both the sites that are broken are hosted by GoDaddy. Someone suggested that I try restarting Apache, but I don't appear to have the power to do this and I have no idea if it would even help :(
LauraHogarth replied on at Permalink Reply
I am logged in as the admin super user, just FYI.
LauraHogarth replied on at Permalink Reply
Hi again.

I looked on the console in developer tools and saw the following error:

Uncaught TypeError: $(...).orbit is not a function

The line in the code which it refers to is this:

The following error also appeared in the console, with reference to a missing image:
Failed to load resource: the server responded with a status of 404 (Not Found)

Orbit is the image slider which is only in use on the homepage, so I decided to try to edit a different page. I accessed the About Us page via the sitemap, as before (if I try to use the navigation or go there directly, I am logged out). This time, the page appeared editable and I was able to bring up the editable blocks and make changes. However, when I clicked "Save" I got an error as follows (preceded by all the text on the page I was trying to edit):

$(function() {alert('Not Edit Mode');}); var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-39151362-1']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=true;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s);})();

This page showed no errors in the console.

I then tried to edit the Services page in the same way, three times in a row. The first time I was successful, the second time I received an error similar to the one above, and the third time the edit block appeared with an "Access denied" message.

On my personal site, I was able to successfully make an edit on one page in this way (via the sitemap), but when I tried to edit another block on the same page I received the following error:

var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-39151362-2']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=true;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s);})();

I am still completely unable to edit the homepage (and one other page), and I still get logged out when trying to change pages. The pages I cannot edit AT ALL both have a 404 error relating to a stylesheet, whereas the pages I CAN edit (at least partially) have none.

I am way out of my depth here. Any ideas? Thanks for your help so far :)
edbeeny replied on at Permalink Reply
OK can you remove the google tracking code and try editing again.
LauraHogarth replied on at Permalink Reply
Same problems I'm afraid :(

EDIT: Spoke too soon - it does seem to have helped!
LauraHogarth replied on at Permalink Reply
Ok, I just tried checking "stay logged in to website" on the login page (God knows why I hadn't done that before). Either this, or removing the Google tracking code, seems to have removed the logging out problems, as well as most of the editing problems!

I am still having problems on the homepage: I can now click on editable blocks, but I get the "Access Denied" message.

This is on my client's site by the way. I have not yet tried it on my site.

Thanks so much for your help on this - I really appreciate it.
LauraHogarth replied on at Permalink Reply
By the way - the homepage problems apply to global areas (which I can edit without issue from other pages), as well as those which are unique to the homepage.
LauraHogarth replied on at Permalink Reply
I have done the same on my site and it has had the same effect:

The issues with being unexpectedly logged out seem to have disappeared. I can now edit successfully on those pages WITHOUT errors in the console. On the homepage (and the other page with a console) I get "Access Denied" when trying to edit blocks.

I will look into solving these errors and see if it makes a difference!
edbeeny replied on at Permalink Reply
Seems you have a small javascript error somewhere.

Good luck if you need anything else just shout.