Home Page Editing Broken

Permalink
Edit mode on my homepage is broken. All the other pages are normal, and work like they should.

Problems (only for trying to edit the homepage):
1. The Add Block menu and the Gear menu (Page Design, Location, Attributes and Settings) does not open. Clicking it only changes the URL to example.com/index.php?cID=1#.
2. Clicking on the button on the toolbar that would open the little Dashboard menu does not work. It takes me to the main Dashboard.
3. When I go to the Dashboard page from the homepage, it is messed up. The menus are out of order. The menu is normal from any other page.
4. When I enter edit mode, I can highlight the blocks, but clicking on them does not open the block menu.

I cleared the cache, but that did not help. I have not made any changes recently to any php file. I have tried editing on multiple computers.

This seems like a JavaScript error.

EngineerofStuff
View Replies: View Best Answer
EngineerofStuff replied on at Permalink Best Answer Reply
EngineerofStuff
I fixed it.

I had put some extra header content containing the Nicescroll code. I didn't need it anymore, so I had removed the required files from my site, but forgot to remove the html code from my site. For some reason, the broken code did not affect anything until now.