Homepage: page not found

Permalink
Hello guys,

I have an issue which I could not solve yet and it is starting to get very urgent by now.
On the website that I manage (https://www.immanuelkerkveldhoven.nl) the home page is not loading giving a page not found error.

However, if I directly browse to a sub-page (i.e.https://immanuelkerkveldhoven.nl/activiteiten)... all works well.

If I log in (by directly browsing to the dashboard) and check my sitemap I can see my normal home page in the sitemap. The last version is indicated as live.

A rough overview of things I have tried:
-Approve an older version of the home page
-Duplicate the last version and approve it
-Cleared cache
-Turned off pretty urls
-I made a copy of the home page which now a normal page on the level below (https://www.immanuelkerkveldhoven.nl/home) which works fine

The only lead I still have is that I had tried to use timed approval of this page. But I can't find anything related to that.

Does anybody have an idea how to solve this or what to look at?
This is the website of my church and this form of communication is now more important than ever...
Thanks a lot!

View Replies:
hutman replied on at Permalink Reply
hutman
When I accesshttps://www.immanuelkerkveldhoven.nl/... I am able to see the homepage without issue.

Is this only happening when you are logged in?
wdegeus replied on at Permalink Reply
Wow... I just checked from my phone and indeed it works!
I am quite puzzled at what is/was the rootcause, but at least the issue is much less severe than I thought.

Tomorrow I will check whether it works on my laptop as well.

Thanks for checking!
Gondwana replied on at Permalink Reply
Gondwana
Browser (or some other) cache, maybe?
wdegeus replied on at Permalink Reply
Just checked on my laptop. It was browser cache indeed. This could have saved me a lot of time... :-). Anyway, thanks for the quick response guys!