Hover in Image Block is not working

Permalink 2 users found helpful
Hello, I added a hover image in the image block but its not appearing even though the image appear to be changing when i inspect the code. I tried this on Elemental theme also not working.

Can someone help me please? thanks in advance

Doodlimah
View Replies: View Best Answer
fudyartanto replied on at Permalink Reply
fudyartanto
You have url..? please submit here so we can help.
Doodlimah replied on at Permalink Reply
Doodlimah
fudyartanto replied on at Permalink Reply 1 Attachment
fudyartanto
Seems everything ok (see attached), image changed when hover. or maybe I check wrong area..?

what kind of your browser..?
Doodlimah replied on at Permalink Reply 1 Attachment
Doodlimah
I'm using Chrome and its not working (Please see the attached image), i checked it on Firefox and Safari and even IE its working fine on all of them! the problem seems to be only in Chrome!
Steevb replied on at Permalink Reply
Steevb
View your source code, you will see there are a lot code errors.

Use the validator to help as well:http://validator.w3.org/
Doodlimah replied on at Permalink Reply
Doodlimah
Thank you I'll check them
fudyartanto replied on at Permalink Reply
fudyartanto
mm.. I know why this happened. Chrome cache issue.

See this discussion.
http://stackoverflow.com/questions/10865689/clear-an-img-with-jquer...

I'll back with custom template. so you can use it as alternative solution.

I report this issue as bug, please help me to confirm the issue.
http://www.concrete5.org/developers/bugs/5-7-3-1/hover-function-in-...
Doodlimah replied on at Permalink Reply
Doodlimah
Thank you very much
fudyartanto replied on at Permalink Best Answer Reply 1 Attachment
fudyartanto
See attached. that is custom template for image block. Already test and work in chrome.
To install custom template.

1. put zip file under \application\blocks
2. extract the zip
3. edit your block > design > custom template > choose hover > then hit save

So the idea is create two tag image. 1 as primary and 1 as on hover image. When initial the page hide the hover image. When In hover state show image 2 (hover image) then hide image 1 (primary image).

In community don't forget to mark the best answer. cheers..
Doodlimah replied on at Permalink Reply
Doodlimah
Thank You very much, it worked like a charm, thanks a lot for your help
MarcYBB replied on at Permalink Reply
MarcYBB
Thank you for the fix.
Took about 1 minute and it works like a charm.
lyc replied on at Permalink Reply
Hello,

The issue is quite easy to solve. But this is still a bug.
https://www.concrete5.org/developers/bugs/5-7-5-1/images-hover-rollo...

"The problem is that, in order to make the hover effect work properly, it is absolutely necessary to force image maximum size (in the options of the image block)."

You should confirm please that this is a bug.

Thanks,
Steevb replied on at Permalink Reply
Steevb
Sorry, Away until the 10th September 2015