How to change default theme in composer

Permalink 3 users found helpful
Hey Everyone,

I've got a custom theme that I use through out my site but when I use composer to create a blog entry page the default theme is "Greek Yogurt" even though I've activated my custom theme and it's the theme used it the parent page.

Also composer has options for "Header Image" and "Thumbnail". I'd like to remove these but cannot find where to remove them from page types defaults.

So any help with either of these problems I'd be very thankful.

Russ

View Replies: View Best Answer
Mainio replied on at Permalink Reply
Mainio
For the composer settings I think you'll find this page very helpful:
http://www.concrete5.org/index.php?cID=267862...

There is straight explanation how you can setup / remove content sections from composer.

For the theme issue, you'll have to wait for other answer, sorry I can't help you with that. I'd suggest at least checking also that the sub-pages don't have any theme overrides.

Antti / Mainio
cannonf700 replied on at Permalink Reply
cannonf700
there's a good chance that your custom theme doesn't have the blog_entry.php page type that composer is posting as/to. check out this Tutorial for help in changing the settings and what not:

http://www.rynomediaonline.com/resources/tutorial-on-concrete5-s-co...
sarah3585 replied on at Permalink Reply
sarah3585
I also cannot seem to find out how to remove an attribute for composer. Using the Greek Yog theme it comes with Header image, thumb image and tags already set up.
I go to 'Defaults' on the Blog Entry page type, I see the tags and thumb areas set up but there is no header on the page to then remove it.
Any ideas? Many thanks!
Mainio replied on at Permalink Reply
Mainio
When in the page defaults section, click on the area that is included in the composer and under the menu you see "Composer Settings".

There you can disable that area in the composer.
sarah3585 replied on at Permalink Reply
sarah3585
Many thanks for the reply. The header item is not in the default page type to delete, so I'm a little baffeled to where that's coming from?

Also where does the thumb image get its width and height settings from, I can't see it listed in Attributes
sarah3585 replied on at Permalink Reply
sarah3585
Ah found it.

If anyone else is interested look in blocks > choose the block type - 'image' in my case > composer > thumb.php (in my case)

Still can't figure out how to get rid of the Header image mind
Mainio replied on at Permalink Reply
Mainio
Probably you're looking from the wrong page type.

If in default installation, these are under the Blog Entry page type defaults.
sarah3585 replied on at Permalink Reply 1 Attachment
sarah3585
I believe that's where I'm going. See screenshot
Mainio replied on at Permalink Reply
Mainio
Have you clicked it to the edit mode after clicking that button?
sarah3585 replied on at Permalink Reply
sarah3585
Yes I have. There's a thumbnail block where I can choose Composer Settings but no header image to remove.
Mainio replied on at Permalink Reply
Mainio
Could you send a screenshot of that state as well?
sarah3585 replied on at Permalink Reply 1 Attachment
sarah3585
Sure.
Mainio replied on at Permalink Reply
Mainio
Oh, ok, now I got it.

You're not using the default template, so you might want to change your theme to the "Greek Yogurt" one while you do the change. There's the area missing from your template that contains the header image.

Other option is in your current theme to add a new area with name "Header Image".

That can be added with this code in your theme:
<?php 
   $a = new Area('Header Image');
   $a->display($c);
?>
sarah3585 replied on at Permalink Reply
sarah3585
Cool thanks, I've added that code and all good. I checked the greek yogurt theme that i worked from and it does not contain that code.

Many thanks for your help!
craftsman841 replied on at Permalink Reply
I'm having the same problem regarding removing the thumbnail and header image from composer. I can't find it anywhere in page types to remove.
russgrue replied on at Permalink Best Answer Reply
Ok.. Looks like I've figured this out...

For the custon theme, by activating a random theme then re-activating my custom theme has now made my custom theme the default in composer.. This isn't idea as the preference SHOULD be for what ever the parents theme is should be the default theme for published pages for the case where multiple themes are used in a single site.

As for the "thumbnail" and other options in composer they were configured when "Greek_Yogurt" was default theme. By making it the "Activated" theme then going to page defaults deleteing those blocks then changing the default theme again.

Hope this helps everyone!

Russ
tgroff replied on at Permalink Reply
Wow, what a pain this was to figure out, this had me completely baffled! Thank you @russgrue for posting your solution!
twpaige replied on at Permalink Reply
Thanks Russ! That did the trick. :)
BermudaSam replied on at Permalink Reply
Where exactly should the theme be switched back and forth? I tried re-activating my custom theme on the blog index -page (ie. the parent for individual pages made via Composer) and on the default page type set to be used in Composer. Both failed.

I am using C5 version 5.6.2.1 and had the blog created at installation. Then I created a custom theme, and am now stuck with "Greek Yogurt" theme on new pages created in the Composer. I actually deleted the "Greek Yogurt" theme, just to see if it made any difference - after that the new pages get no theme at all...
jpgriffin replied on at Permalink Reply
jpgriffin
I have this same issue. Page defaults for the blog_entry page shows my custom theme fine but as soon as I publish/preview from Composer the blog page reverts to previous theme.
jpgriffin replied on at Permalink Reply
jpgriffin
Think I found the answer. I activated another theme across the whole site and then re-activated my custom theme across whole site.

Composer now publishes and previews using my custom theme. Phew . . .
BermudaSam replied on at Permalink Reply
That did the trick! Thanks a lot!