Login redirect on page_forbidden

Permalink
I've tested the page_forbidden single page which works fine when logged in as an admin. However, when a guest views the page it redirects to the login page.

Someone else had the same issue 9 years ago:
https://concrete5.org/community/forums/customizing_c5/login-form-on-...

Is it just me, or is this bug still there?

FYI, I've tried the following steps:
- clearing the cache
- checked the permissions for the page from the sitemap ("guest" can access it)
- enabling & disabling custom theming (https://documentation.concrete5.org/developers/designing-for-concrete5/applying-your-theme-to-single-pages-with-theme-paths)
- added and removed a single page file within the theme to style the page (called "page_forbidden.php")

Anyone else getting the same issue?

jb1
View Replies:
Elstud replied on at Permalink Reply
Elstud
So, did you try this solution as was indicated a few years ago?

you can then try a 301 redirect in your .htaccess.


Redirect 301 /page_forbidden.php http://www.sitename.com/errorpagename
jb1 replied on at Permalink Reply
jb1
yeah, I tried that but it took no effect. Still get the redirection to the login form. I'm a bit stumped.
jb1 replied on at Permalink Reply
jb1
Thanks to Jon Morris on Slack who suggested adjusting this config value - in case it helps anyone else with the same issue:

https://github.com/concrete5/concrete5/blob/80dfd7d8fc9bfa305a703c1a...

Setting this flag to false prevents guests from being redirected when they view a page they're not supposed to (such as /dashboard).