Memoryissue - concrete 5 has encountered an issue

Permalink
every time I try to upload a gallery - both simple or grand gallery I get this message:

Whoops \ Exception \ ErrorException (E_ERROR)
Allowed memory size of 134217728 bytes exhausted (tried to allocate 32444417 bytes)

The images I try to upload are downsized to minimum and still this msg shows.

My page:http://www.cathi.no - and the spesific page I am trying to edit:https://www.cathi.no/kunstprosjekter/avtrykk-fra-museumshaven...

Adding a picture of the screen.

I have no idea how to fix this. Can someone lead me to a step-by-step fix the memoryissue?

1 Attachment

cathfins
View Replies:
Gondwana replied on at Permalink Reply
Gondwana
Could be the built-in image resizing. I think there's a couple of options for how it's done. One is more memory-efficient than the other, but may require an extra php extension to be enabled. I know this is vague (and possibly wrong), but hopefully it helps.
lukasznillo replied on at Permalink Reply
lukasznillo
I had a similar problem with a server with a small amount of memory. In part, the problem was solved by enabling the ImageMagick library (in PHP settings) instead of GD which is less efficient, consumes more memory for operations on photos. Of course, if your server provides the option to enable these extensions. After adding the extension, in the Concrete5 image settings you need to change the library to ImageMagick and try. In my case it helped
cathfins replied on at Permalink Reply
cathfins
Changed settings to image magic library - and there is a gallery, but now I can not get the thumbnails to show om the gallerypage.just textlinks to the larger pictures.
Any idea what I miss?
Gondwana replied on at Permalink Reply
Gondwana
Are you sure that the ImageMagick php extension is installed and enabled? This can't be done within concrete5.

If you did, then you could try the option to rebuild thumbnails. Clearing the cache (including thumbnails) might also help. Dunno.
lukasznillo replied on at Permalink Reply
lukasznillo
or if that doesn't work, add the gallery block again. Just make sure you have ImageMagic extension enabled in your server's PHP settings