Multiple File Upload problem - RESEARCHED UNSOLVED!!! HELP!!

Permalink
Hi all, I have been painstakingly trying to get a new site fixed with no luck so far. Ive searched the forums for a possible solution and came up with many suggestions however nothing has worked this far.

I get this error when i try to upload via multiple uploader (locally)...
An unknown error occurred while uploading the file. Please check that file uploads are enabled, and that your file does not exceed the size of the post_max_size or upload_max_filesize variables. File Uploads: 1 Max Upload File Size: 100M Post Max Size: 100M
.

When the site is hosted on our dev server, i get a ERROR 401 when using multiple uploader..

Uploading via the incoming folder works as expected....


These are my settings so far...
Concrete 5.6.3 (have tested this as a fresh install and an upgrade on a site...) and both have exhibited the same error (which leads me to believe its something to do with our setup or servers or php).

I am running the latest version of MAMP (3.0.3), php5.4.25 (see settings below)..

# concrete5 Version
5.6.3

# concrete5 Packages
Advanced Forms (1.11.1), Area Splitter (2.1), Royal Slider (9.5.1).

# concrete5 Overrides
blocks/autonav, blocks/content, blocks/matogertel_area_splitter, blocks/page_list, blocks/royal_slider, blocks/search, blocks/tags, single_pages/login.php, single_pages/page_not_found.php, single_pages/register.php, themes/bootstrap

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off

# Server Software
Apache

# Server API
apache2handler

# PHP Version
5.4.25

# PHP Extensions
apache2handler, apc, bcmath, bz2, calendar, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, intl, json, ldap, libxml, mbstring, mcrypt, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, Reflection, session, SimpleXML, soap, sockets, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, xsl, yaz, zip, zlib.

# PHP Settings
max_execution_time - 90
apc.max_file_size - 1M
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 90
max_input_vars - 1000
memory_limit - 128M
post_max_size - 100M
sql.safe_mode - Off
upload_max_filesize - 100M
ldap.max_links - Unlimited
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5


I have tried the suggestions on all of the following posts (listed with links below...) but no luck still, hoping someone can help me figure this out!

http://www.concrete5.org/community/forums/usage/error_trying_to_upl...
http://www.concrete5.org/community/forums/installation/upload-files...
http://www.concrete5.org/community/forums/usage/error_on_andquotupl...
http://www.concrete5.org/community/forums/installation/solved-uploa...

jpcharrier
View Replies:
shondy replied on at Permalink Reply
shondy
This is typically something you can adjust in your php.ini file, which in XAMPP (yeah, I'm a windows guy) is in the php named file in the XAMPP root directory.

Look for strings like "upload_max_filessize" and change the value to something larger. Also, look at "max_file_uploads".

Have you tried to upload smaller files, or fewer files at once? What is the tipping point? Nothing like a good process of elimination.

Keep in mind that on most shared hosting accounts you wouldn't have access to the php.ini file so you may need to contact the hosting company to see if they can make the changes you may require.
jpcharrier replied on at Permalink Reply
jpcharrier
Thanks for that...

Yes i have edited those in my php.ini settings you can see above...
upload_max_filesize was increased to 100M, max_file_uploads increased to 20..

Ive even tried uploading one single file through the multiple upload interface. usually uploading between 7-12 files, max individual file size does not exceed 50kb (so total would nowhere be near max_filesize).

No tipping point, it just always happens no matter what size file, or how many.... Have also tried uploading various sized images as small as 1kb, as large as 700kb.

Any other ideas to check?
Steevb replied on at Permalink Reply
Steevb
5.6.3 Multiple file uploads do not work with Firefox or Safari, you need to use Chrome.
jpcharrier replied on at Permalink Reply
jpcharrier
Is this a known issue? That sounds pretty major im surprised there was not a warning on the download/update page about this.
mnakalay replied on at Permalink Reply
mnakalay
jpcharrier replied on at Permalink Reply
jpcharrier
Yes thanks mnakalay, ive found that... Not good at all!

I really hope they change their attitude to "This will be fixed in 5.7" as there are many 5.6 sites that wont want to upgrade (plus the added client training)...

For a stable release, this really should be addressed.
JohntheFish replied on at Permalink Reply
JohntheFish
If you want a user friendly alternative, have a look at my Front End File Uploader block.
http://www.concrete5.org/marketplace/addons/front-end-file-uploader...
pvrs2006 replied on at Permalink Reply
single and multiple file was worked fine in my local but after uploaded the same source codes to server its not working.

I couldn't find any error logs.

i did the php.ini configuration also it not working.

file_uploads = On
upload_max_filesize = 100M
post_max_size = 100M
upload_tmp_dir = /tmp/

Please help me on this. site already in live
jpcharrier replied on at Permalink Reply
jpcharrier
What version of C5 are you using..? Can you post the environment information from your c5 site from live?
pvrs2006 replied on at Permalink Reply
Yes, I'm using most recent one. Concrete 5.6
jpcharrier replied on at Permalink Reply
jpcharrier
Cool can you post from your environment information? That might give some clues in there...
pvrs2006 replied on at Permalink Reply
Thanks for your quick response and unfortunately I cannot share the hosting details due to security concern.
pvrs2006 replied on at Permalink Reply 2 Attachments
Here with i have attached the screenshot for uploading issues.
During the upload I cannot see anything on the firefox firebug console.

I remember last week I have registered the local with community. I really not to sure this is causing issue?
jpcharrier replied on at Permalink Reply
jpcharrier
You haven't set your php.ini file right it still says 2M and 8M it could be running out of memory also?

> On 12/09/2014, at 2:00 pm, concrete5 Community <[email protected]> wrote:
pvrs2006 replied on at Permalink Reply
You mean configuration will be 100M for upload and post max size?


upload_max_filesize = 100M
post_max_size = 100M