non-admin users can't add blocks to pages they have edit permission for

Permalink 1 user found helpful
We have a Staff group for non-admins. Recently (possibly since the upgrade to, members of the Staff group can't add blocks to pages. The user permissions show that the users have the Staff group, and the page permissions show that Staff can view and edit the page. The users can indeed edit the page (change properties/design etc), but when they click on "Add to Header" and "Add to Main", the pop-up menu only includes "Add Layout" and "Design" - the other expected options like "Add block" and "Paste from Clipboard" are missing.

We have tried logging in as different users, using different browsers on different machines, editing different pages, using different themes, and clearing concrete5's cache.

We do not use Advanced Permissions. Should I enable them? What else can we change?

View Replies:
harleyjw replied on at Permalink Reply
Switched to Advanced Permissions, but that didn't fix it.
adajad replied on at Permalink Reply
Have you checked your page type permissions? Perhaps you have restricted permissions on the page types which are then inherited when the pages are in use.

If you do make changes to your page types, don't forget to 'Setup on Child Pages' when you are done, to have the changes applied to all pages already using the page type(s).
harleyjw replied on at Permalink Reply
That's interesting - I didn't know page types could have permissions, and I can see that being useful - but no, all my page types are set to "Assign Permissions by Area of Site"
harleyjw replied on at Permalink Reply
Cracked it. It turns out that when you edit a page as an admin, and click on "Add to Main", you now get an option to "Set Permissions" which includes a permission to be able to add block, which was inexplicably turned off for group Staff even though they had permission to edit the page. (If this weird behaviour was in the release notes, I missed it!)

Giving Staff the Add Block permission on Main on a page at the top of the hierarchy turned it on for all pages below, thankfully.
jodzeee replied on at Permalink Reply
Is it just me or is setting permissions way more difficult than it used to be? I'm looking in the documentation and the screen shots shown are way more intuitive than what I'm dealing with.

I attempted to create a user and set the permissions appropriately, but it didn't work. So I'm trying again and rather than click on each individual permission, add group, etc. I thought maybe it'd be easier to do it by page type and just do it once.

But how do I assign/change permissions to a page type?
sabumnimdk replied on at Permalink Reply
Hi everyone,

I have been spending most of my evening working with and setting up Advanced permissions on a site.

I ran into the same isues as you mentioned in this thread, and got really stuck.

I then watched this video:
and found the solution to my advanced permissions problems.

As it turns out, the 5.6 version has a new feature.
Go to Dashboard >> Stacks and Blocks >> Block & Stack Permissions >> Choose the Add Block option and add your USER.

When this is done, you can access a specific Page Type, and use the Set Permission on any specific area on this Page Type, where you want the USER to be able to only ADD SPECIFIC BLOCK TYPES.

Now when you log in as this USER, and choose ADD BLOCK, you should only get a list of the chosen Block Types.

Hopes this helps you in your continued quest :-)

Best regards
//Carsten - Denmark
TorstenKelsch replied on at Permalink Reply
Oh my golly, this is hard to find in deed. Thank you for posting this, I was almost going nuts before reading your hint. I wonder why this permission control is not additionally located at System & Settings > Permissions & Access. Very confusing!
nesoor replied on at Permalink Reply
Thank you for sharing this information!
mlipenk replied on at Permalink Reply
After initially setting up concrete5 version 5.6.1, I created some groups and then as the Admin I gave permissions to a group on individual pages. When I logged in as a user, the only thing users within that group could do was "Add Layout" and "Add Design". Not what I expected.

Then, as an Admin, I went into the Dashboard under "Systems & Settings" > "Permissions & Access" > "Site Access". There is where I gave "Edit Access" to the group(s) because they were all turned off by default. Then I went back to the pages and gave permissions to groups on a page-by-page basis. I logged in as a user, and the "Add Blocks" and other edit capabilities were available to those groups, specified on those pages.

Ironically, when I went back into the Dashboard under "Systems & Settings" > "Permissions & Access" > "Site Access", the Edit Access selections were then de-selected again, but Concrete5 does state right there: "Note: These settings can be overridden on specific pages." which I did in fact do as an Admin.

My question is, why as a user I am able to remove my own permissions, thus removing my ability to edit??? Doesn't make sense. I must be missing something.
nesoor replied on at Permalink Reply
So far as I know you can turn this off by going to
"Edit > Permissions > Edit Permissions" delete any group accept administrator.

I am just using C5 for a few days now so this is what I know, I hope it helps!
harleyjw replied on at Permalink Reply
We use groups to give different sets of users different permissions, so deleting our groups is not an option.

For anyone reading this in future - this problem still occurs with the latest Concrete5 out-of-the-box as of If you create groups, you have to manually give each group permission to add blocks to pages, even when that group already has permission to edit the page.