Object not found!

Permalink
So i get the message

"Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404
192.168.0.68
Sun Dec 21 18:36:28 2008
Apache/2.2.8 (Linux/SUSE)"

I get this on every page other than the home page, even when i go to log in. please help

daryl
View Replies:
daryl replied on at Permalink Reply
daryl
ok so i think i might be able to fix it but im not sure. when my site went to hell i had changed the setting on the "pretty URL" thing. now im not sure if its possible but i think that if i put the required code in the server's configuration file or .htaccess file it might fix it. however im not exactly sure where to find this file. ive looked and there is no .htaccess file.
please help
daryl replied on at Permalink Reply
daryl
so i found out that when i put /index.php/ in the address bar it will go to the page that i specify but i cant login to change the pretty url setting. i type in my site/index.php/login and the login page comes up, i put in my username and password but when i hit submit i cant but in /index.php/ so i get the same error massage
please help
daryl replied on at Permalink Reply
daryl
so i found out that when i put /index.php/ in the address bar it will go to the page that i specify but i cant login to change the pretty url setting. i type in my site/index.php/login and the login page comes up, i put in my username and password but when i hit submit i cant but in /index.php/ so i get the same error massage
please help
frz replied on at Permalink Reply
frz
well.. lets see..

did it work before?
did something change?
is there a link to a php_info call on your sever somewhere you can share?
synlag replied on at Permalink Reply
synlag
maybe your provider has a problem with php5?
i got this message because of that and had to add .php5 to the file endings...
But there's another way to get this working.

you have to add an extension to your .htaccess file in the root directory of your server, which depends on the configuration of your provider.

i think you should ask your support for the right lines to add.

Best Regards
daryl replied on at Permalink Reply
daryl
so i found my .htaccess file and copied the required code into it. as far as i know this is what the code is right?
"<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>"

i just put it at the bottom of the text. is that alright?
daryl replied on at Permalink Reply
daryl
this did not work.
please help
daryl replied on at Permalink Reply
daryl
it all worked just fine until i touched the pretty url option in the sitewide setting of the dashboard. i would have no problem changing it back if only i could login.
ScottC replied on at Permalink Reply
ScottC
siteroot/index.php/login.php ?
daryl replied on at Permalink Reply
daryl
ya that works for getting me to the login page but as soon as i put in my username and password it wont login. i get the same error message
ScottC replied on at Permalink Reply
ScottC
http://siteroot/index.php/dashboard

otherwise just re-upload, IE repave and reinstall it.

I don't run pretty URLs yet either and I am somewhat familiar with the cms at this point :)

Or if you can get to your db through phpmyadmin or whatever db administration software navigate to your db, go to the config table, there is a field there that for me is null called URL_REWRITING. I think if this is a 1 or something like that then it is tryign to do the pretty url stuff.

edit: so set that field to null, I don't see andrew or the c5 team repeating themselves anywhere so that row/field must be set to something other than null.
daryl replied on at Permalink Reply
daryl
thanks for your help but i just ended up reinstalling. it was quite easy just to copy all the information over and in hindsight i think i should have done this from the beginning and saved myself a lot of headache.