PAGE NOT FOUND ERROR WHEN TRYING TO VISIT NEW PAGES ADDED TO WEBSITE

Permalink 2 users found helpful
Hi,
I am very new at this and I was able to build My website with Parent pages and additional pages. I can see and edit all the new pages I created perfectly, but when I go to my main website to view it - All that shows up is my Homepage. The website gives me the following error messages if I try to select any other Nav tabs/pages:
PAGE NOT FOUND -
The page you are looking for might have been removed, had it's name changed or is temporarily unavailable.
I have no clue how to fix this, so that my new pages show up? Can you help?
Please explain in detail as I am no computer genius. Thank you so much for the help.
In case you want to see the error you can vistahttp://www.earthme.org and just click on any of tabs. You will see what I am writing about. Thxs agn!!

earthmeorg
View Replies: View Best Answer
Mnkras replied on at Permalink Reply
Mnkras
In the dashboard, under sitewide settings, there is some code that you need to stick in the .htaccess file, or you have to disable pretty urls
cursal replied on at Permalink Reply
cursal
I'm not sure what happened to cause the same thing to start happening on my site.

I built pretty much the whole site, then one day after adding a page and editing it, I could NO LONGER access the page from the auto-nav.

I never enabled pretty URLs, but also see my .htaccess file is gone.
I don;t recall deleting it, so I copied one from another site I have, but no help.

The page is accessible from sitemap and dashboard ONLY

Solutions?
mkly replied on at Permalink Best Answer Reply
mkly
You shouldn't need an .htaccess at all with pretty URLs turned off. Try these steps out and see where it gets you.

Make sure pretty URLs are not enabled by going to
Dashboard->System Settings->Pretty URLs
uncheck Enable Pretty URLs

Clear the cache by going to
Dashboard->System Settings->Speed Settings
and clicking "Clear Cache"

If it is only that one page you cannot access try to access it via the sitemap at
Dashboard->Sitemap
Click on the Page and select Visit
Check what the URL is for that.

Also check what the "alias" of the page is.
Click Edit Page then Properties then Page Paths and Location
What does it have there?
Is this different than the link from the nav?
earthmeorg replied on at Permalink Reply
earthmeorg
Dear mkly,

Thank you so much for the detailed explanation in a language that we could understand.
We did have the Pretty URL box checked and after I unchecked it we still had a error message. I took the next step and "clear cache", which I still don't know what that does at this point, but it worked!! Our error pages are gone and the website is up and running like it should.
Thank you so much for your help!
Kind regards,
The Earthme.org team
mkly replied on at Permalink Reply
mkly
Clearing the cache clears some data that is used to avoid looking things up again when displaying a page. Some of this "Cached" data includes the Pretty URL links. So if you disable Pretty URLs after they have been on you sometimes have to clear the cache to reset that data or those links will still point to the pretty URL links.

Clearing the cache is a pretty good thing to try in general when something seems a little sideways.

Glad you got it sorted.
cursal replied on at Permalink Reply
cursal
I am still get Error pages..any other ideas?

What I checked
-Pretty URLs are not enabled (never were)

-Clear the cache: not only via dashboard, but deleted theme off the server

-Dashboard->Sitemap -> Check what the URL is for that.
I get: index.php?cID=130
when I click on the auto-nav link
I get: index.php/wbn-shop/

Also check what the "alias" of the page is.
Mine is: wbn-shop

TIA
cursal replied on at Permalink Reply
cursal
Will PAY for this to get working.
I don't have the time right now.

HELP please!
JohntheFish replied on at Permalink Reply
JohntheFish
Just a thought - have you approved the pages you edited?
DBKG replied on at Permalink Reply
Couple of other quick thoughts. Apologies if they are too obvious.

Go to the page that isn't showing up in your menu, click "Edit page"(c5 versions 5.4.2 and earlier; otherwise hover and click on Page Properties), check the Page Properties>Custom Attributes and make sure "Exclude from Nav" isn't checked.

Also, if it's a sub-page that shows up in Site Map under another page (in Site Map, it would be indented), make sure your theme supports a multilevel menu.

Less likely, but also possible, check the page's permissions to make sure it is viewable by Guest.
cursal replied on at Permalink Reply
cursal
Thank you for the input but...

The pages are all approved
The permissions are set proper for Guest and Admin
(note even when logged in and I click on link it goes to the error page)

The page is a parent not a child page.

Strangest thing... just started happening out of the blue..Not even sure what would have caused this. Did not upgrade and still using 5.4.2

Still Willing to pay for some help getting this sorted out.
earthmeorg replied on at Permalink Reply
earthmeorg
Hi,
Thank you so much for the help!
It's up and running like it should now. Yeah!
cursal replied on at Permalink Reply
cursal
The problem has been solved.

I contacted Steve (http://www.concrete5.org/profile/-/11219/) here on the forums and he found the trouble.

Seems that when you install C5 into a sub-directory, and then try and name a page that starts with the name of the sub-directory it throws the error.

Example.
If you install c5 athttp://www.yousite.com/irock

you cannot name a page irock-online or irock, or anything with the same characters as the sub-directory.

Whew, glad is was a simple "fix" but does seem like a bug in the core.
Thank you Steve fromhttp://www.perceptualmediaworks.com/...
Shotster replied on at Permalink Reply
Shotster
Jonnow replied on at Permalink Reply
Ahh this solved my issue! Thanks 4 years later!
arlenesey replied on at Permalink Reply
arlenesey
The "Most Helpful Answer" highlighted in green also helped me when I wanted to change a menu item name at a later date. I thought I could simply change the page name and URL slug in SEO, but I had to turn off pretty URLs, and correct each individual page -also the subpages - under the "gear" -> "Location". Then cleared cache and reenabled pretty URLs. Whew !