Page redirect is redirecting even though I turned it off

Hi C5,

I have been pulling out my hair trying to figure this out so I am looking for some guidance:

1) Via the attributes page for a page on my site, let's call it "Page1', I turned on the redirect attribute and pointed it to a "Coming Soon" page because I was still working on Page1.
2) Page1 was completed so via its attribute page I turned off that attribute (clicked the little box and it disappeared)
3) When I try to navigate to Page1 via the autonav menu, "Coming Soon" is served up.
4) When I try to navigate to Page1 via the Sitemap (from the link under Dashboard- call this Sitemap1) "Coming Soon" is served up.
5) When I try to navigate to Page 1 via the Sitemap on the link next to the Dashboard (icon looks like 2 documents with the top left corner folder over - call this Sitemap2) I get Page1!
6) I can get to Page1 via a hyperlink if the hyperlink references the cID...

It seems that Sitemap2 uses cID to call up the page and Sitemap1 uses the canonical address... Whatever the convoluted logic for having 2 sitemaps that don't map to the same page I won't even hazard a guess...

I tried to simply delete the Redirect and Page selector add-ons from the Extend concrete5 dashboard page but I get this error:
An exception occurred while executing 'DELETE FROM AttributeKeys WHERE akID = ?' with params [61]: SQLSTATE[23000]: Integrity constraint violation: 1451 Cannot delete or update a parent row: a foreign key constraint fails (`arvcon1_conc336`.`atEmptySettings`, CONSTRAINT `FK_ED1BF189B6561A7E` FOREIGN KEY (`akID`) REFERENCES `AttributeKeys` (`akID`))

I have cleared the cache 30 times. Signed in and out numerous times. Reindexed the site. Generated the sitemap over and over again hoping that the reference for redirection would be overwritten somehow, somewhere.

I haven't turned off Pretty URLs and the options to only use canonical URLs for fear of not being to able to access anything...

What to do? I can't call the page anything other than "Page1" because it is specific to the product on that page (it would be like calling a page about Cars, Chickens).

Help please.

View Replies: View Best Answer
hutman replied on at Permalink Best Answer Reply
Can you provide a link to the site with an explanation of which page is having the issue? This could be an autonav caching issue, it could be a browser cache issue (have you tried multiple browsers?), or it could be something totally different that we might be able to see from the link.
MarcYBB replied on at Permalink Reply
Thank you, hutman...
It was the browser cache. I work in Chrome so I switched to Firefox and it worked. Cleared Chrome's cache and problem solved.
That's why I like C5... great community is always there to help!