Pretty URLs Generating a 404 - Help pls!

Permalink
Hello - I'm building my first site with Concrete5 but have run into problems re-writing the URLs with Pretty URLs.

I have enabled Pretty URLs and added the required code to .htaccess. When I click on the navbar links I get a 404 not found error.

The URL appears as:
http://www.jwgconsulting.com/concrete5/about/...
and generates the 404.

Adding index.php to the URL works:
http://www.jwgconsulting.com/concrete5/index.php/about/...

I truly appreciate any help! I'm using C5 Version
5.4.1.1 with Apache and PHP 5.2.17.

Thanks :)

Dan

View Replies:
olliephillips replied on at Permalink Reply
olliephillips
I'd look around the installation help forum for .htaccess tweaks. Some hosts require a slightly different rule set in order to perform the redirect successfully.
rritz replied on at Permalink Reply
rritz
I have the same problem too, did all and everything my host told me and other users told me to do.
I didn´t get it resolved, so I reported a bug.
Still nothing is happening.
Maybe you could also report a bug. If all these users here reported the pretty url bug, then maybe someone would solve it.
nteaviation replied on at Permalink Reply
nteaviation
I don't believe it is a C5 bug. It is most likely an webserver/php configuration issue. I have had issues many times with "pretty URLS" and the resolution allway turned out to be a configuation problem either on your side or your web host's side.
madeforspace replied on at Permalink Reply
madeforspace
I see the first link has /concrete5/about/ in it.
Should that not be /about/
I am a little unsure why there is a concrete5 in the URL at all unless that is the directory you have it in. The file structure is probably the cause of the problem.
nteaviation replied on at Permalink Reply
nteaviation
Good catch Madeforspace. I would bet you need a
RewriteBase /concrete5/
in your .htaccess file.
madeforspace replied on at Permalink Reply
madeforspace
nteaviation code suggestion sounds like a good one to me, let us know how you get on.
dmgriffiths replied on at Permalink Reply
Thanks, the site is in the /concrete5/ directory. Adding that into RewriteBase doesn't help. :(

I've confirmed rewriting is enabled. Thinking now it may be the regexp - I see from other posts some hosts have a problem with this line: RewriteRule ^(.*)$ index.php/$1 [L]

Appreciate any other ideas - thanks all
garynobles replied on at Permalink Reply
charity671 replied on at Permalink Reply
Here is how to enable Pretty URL's when using Concrete5 on GoDaddy

http://support.godaddy.com/help/article/7505/enabling-search-engine...