Problem with SSL Redirect Add-On

Permalink
I made a rookie mistake and am now locked out of my site. I used an SSL redirect add-on (http://www.concrete5.org/marketplace/addons/ssl-redirect-configuration) and should have paid attention the "expert" notation on it.

I installed it and now cannot access my site at all. It's being redirected to https - just like it's supposed to - but I didn't configure the domain correctly so I'm locked out.

I just want to get rid of it and go back to my site the way it was. If I go into my file manager, there is an application>config>generated_overrides folder. If I delete that, will that do it, or will I make it worse? Any suggestions for a semi-novice who is kicking herself for doing something stupid?

Thanks,
-T

View Replies:
hutman replied on at Permalink Reply
hutman
I think if access your site via FTP and comment out the on_start function in that package's controller the site should come up, you might have to delete all the files in the /application/files/cache directory too, but I think that will get your site up.
TMFranklinAuthor replied on at Permalink Reply 1 Attachment
I'm not seeing on_start anywhere... where should I look for that?

-T
hutman replied on at Permalink Reply
hutman
In packages/package_name/controller.php
TMFranklinAuthor replied on at Permalink Reply
This is all of the code in that location...

<?php 
namespace Concrete\Package\ThemeLongStoryShort;
defined('C5_EXECUTE') or die(_("Access Denied."));
use Package;
use BlockType;
use Loader;
use PageTheme;
use AttributeSet;
use PageType;
use PageTemplate;
use Concrete\Core\Attribute\Key\Category as AttributeKeyCategory;
use Concrete\Core\Attribute\Type as AttributeType;
use Concrete\Core\Attribute\Key\CollectionKey as CollectionAttributeKey;
use Concrete\Attribute\Select\Option as SelectAttributeTypeOption;
class Controller extends Package {
mnakalay replied on at Permalink Reply
mnakalay
hello,

see in the code your posted, close to the top, the line that says
protected $pkgHandle = 'theme_long_story_short';

that means you have pasted the controller for your theme's package. The theme is called "Long story short".

you need to look at the controller in packages/ssl_redirect_conf

Also, on the package's market page, the dev explains how you can override your configuration by adding a file. If you do that with the correct configuration it might solve your problem.
TMFranklinAuthor replied on at Permalink Reply
Thanks so much for your help, everyone. I was able to remove the files for the redirect and my site has been restored.

Thanks again!
-T