Problem with TinyMCE and link editor/html editor

Permalink 1 user found helpful
when i add an image and press the image link from the bar, it opens up behind the editor in the webpage? same think with the html source editor. tried, IE firefox and crome, almost the same theme on two other sites work?
Any Ideal were to look/fix this.

-Frank

wizardontherun
View Replies: View Best Answer
wizardontherun replied on at Permalink Reply 1 Attachment
wizardontherun
screen attachment
Mnkras replied on at Permalink Reply
Mnkras
i think thats more a theme problem
wizardontherun replied on at Permalink Reply
wizardontherun
thats what i think but no clue were to start looking?
wizardontherun replied on at Permalink Reply
wizardontherun
does anyone know what i a theme could cause this problem with tinymce?
cannonf700 replied on at Permalink Reply
cannonf700
Have you tried putting your theme's CSS in a 'wrapper'? This is what C5 suggest you do to keep your theme's styles from interfering with C5's core styles.
wizardontherun replied on at Permalink Reply
wizardontherun
how would i wrap it?
cannonf700 replied on at Permalink Best Answer Reply
cannonf700
Check out this thread:
http://www.concrete5.org/help/building_with_concrete5/developers/th...

But basically you make a 'container' for your site and then append all your div's and classes with the name of your container.
If you want you can download a theme I had to do this with here:www.www.rynomediaonline.com/concrete5/black-accents...
and take a look at the main.css file to see what I did.

Another idea might be to take a look at your theme's css and see if you have any outrageous "z-index"'s. This might cause the problem you're having.
wizardontherun replied on at Permalink Reply
wizardontherun
cannon700, i downloaded the theme, but their was no main.css file in it?
cannonf700 replied on at Permalink Reply
cannonf700
PM me and I will send it to you.
I tried attaching it here but it won't let me.
or
I fixed the download from the site I gave above so there is a main.css file now.

Sorry.
SeVeN replied on at Permalink Reply
Same here:
I have an empty standard installation of C5 v.5.4.1. Tested with Chrome and FF.

Is there any solution to this problem/bug?
stoffmann replied on at Permalink Reply 1 Attachment
I have the same issue. But ist not only on inserting links with TinyMCE.
It occurs when i try to insert links, images (as links) and tables.
The attached picture shows what happens when i try to insert a table.
It looks to me as every "window" TinyMCE opens is displayed in the back.
When i close TinyMCE, the window isn't closed and becomes active. Then i can close it using the "Cancel" button.
I have fresh install of C5 5.4.1. I tried the "Plain Yoghurt" theme and the "Dark Chocolate" theme.

Someone got an idea?
SeVeN replied on at Permalink Reply
@stoffmann: I also tried different themes, which didn't make any changes to this problem.

Some ideas which could possibly solve it:

1.) disable the TinyMCE "inlinepopups" plugin.

2.) maybe the german version is to blame (I also us is).

I'll give it a try...


OK, Nr. 1. works for me.
Goto Dashboard -> Sidewide Settings -> General -> Rich Text Editor -> Custom and remove "inlinepopups,"!
Or, in our case: Verwaltung -> Allgemeine Einstellungen -> Allgemein -> Texteditor...
Now those popups open up as usual popup-windows.
stoffmann replied on at Permalink Reply
Thanks SeVeN,

Nr. 1 pointed in the right direction. Aftre removing inlinepopus plugin it works. Maybe it will be fixed in a future version to work with it. Do You know if other editors are supported by C5?
SeVeN replied on at Permalink Reply
Well, actually, my solution is somehow a workaround. Those popups work pretty fine in my c5 test-account at c5host.com (running the same version as my local installation: 5.4.1).

So I guess there is something wrong with my local system OR with the german version.

We will see... I hope to be able to test it tomorrow!

I'm sorry, I'm also quite new to C5; I have no idea of any other editor works well...
stoffmann replied on at Permalink Reply
If you find something, please let me know. Currently the workaround is fine to me.

Thanks again
SeVeN replied on at Permalink Reply
Yeah, there's a bug in the german version:
http://forum.concrete5-cms.de/thread-51.html...

Chico found a solution:
In dem patch_concrete5.4.2_de fehlt der Ordner root/js/tiny_mce/plugins/inlinepopups/skins/concreteMCE in dem die windows.css liegt, die die Formatierung der Popups vornimmt.
Nach kopieren dieses Ordners aus der tinyMCE-Installation im concrete/js/-Ordner funktioniert es wieder.