Problem with uploading file through file manager

Permalink
On latest version of concrete5 (5.6.3) I cannot upload files through file manager. I checked php.ini and everything is ok:
file_uploads = On
upload_max_filesize = 32M
post_max_size = 32M
upload_tmp_dir = /tmp_php/php5

The funny thing is that on that same server I have another concrete5 installed (5.6.2.1) and upload works.

Both installations are in the same domain. I also checked file storage link. It proper.

During installation (5.6.3) it stoped on dashboard install. So I install it on my computer and then moved to server.

Putting php.ini in concrete5 (5.6.3) root gives automatic error 500.
You guys have any sugestions what might help and what is the cause?

Nunchaq
View Replies:
mesuva replied on at Permalink Reply
mesuva
The main thing to check here is the permissions on your /files folder, and any folders within it.

The number one reason why files won't upload in the file manager is that the permissions are set that don't allow files and folders to be created by the user that the webserver is running under. Normally a permission of 755 is what you need.
Nunchaq replied on at Permalink Reply
Nunchaq
Thanks for replay. I checked that too (permision to /files). It is not the case. I think its got to do with script execution time set in php.ini. And maybe this is why latest version crash during dashboard installation.
mesuva replied on at Permalink Reply
mesuva
Can you upload very small files?

Does it actually complete at all, or does it just hang? What actually happens? Error message?

You can check your execution time from the dashboard - /index.php/dashboard/system/environment/info/ (look under # PHP Settings)

But I don't think this would be the cause, it should only take a very short time to process an uploaded file and in most cases PHP is set to at least 30 seconds execution time.
Nunchaq replied on at Permalink Reply
Nunchaq
I tried with very small files (png, 3,6kb and jpg, 3,5kb). There is no error message. It just does not finish uploading. Why I refresh the view I can see that there is incomplete file in file manager.
mesuva replied on at Permalink Reply
mesuva
Have you tried a different browser?

If you use Chrome Developer Tools, you can check the network tab and look for the request to 'single' - this might give you a clue as to what is happening. That request should be returning something like:
<html>
<head>
<script language="javascript">
         highlight = new Array();
      highlight.push(2);
      window.parent.ccm_uploadedFiles.push(2);
      setTimeout(function() { 
         window.parent.ccm_filesUploadedDialog('file1395905859');
         window.parent.ccm_alResetSingle();
      }, 100);
   </script>
</head>
<body>
</body>
</html>
Nunchaq replied on at Permalink Reply
Nunchaq
I'll check if this help. Thank you for advice. But I have returned to 5.6.2 version to finish job for a client.
I installed previous version and it works (installation and uploading are working properly). Other thing I noticed is that in version 5.6.3 constant PASSWORD_SALT was not created (not in config/site.php). Maybe in this version this constant is in different place...