Problems Uploading Multiple Files, "cannot upload zero byte file"

Permalink
I get an error stating "cannot upload zero byte file"

I can upload the files individually, and I can upload them using the incoming folder.

Files is 0777

Can anyone help?? This has never happened on other sites, and only started happening now.

TheRealSean
View Replies:
TheRealSean replied on at Permalink Reply
TheRealSean
The site is being run on a subdomain, The main Domain has safe mode turned off

Hitting Cancel Uploads seems to crash the site
TheRealSean replied on at Permalink Reply
TheRealSean
Can anyone help with this? its crippling the site development at the moment as I only able to upload individual images?
Brainakazariua replied on at Permalink Reply
Brainakazariua
What is the problem if you can both upload them individualy and through the incoming folder? you can easilly get the files on there and into the file manager so basicly it shouldn't delay you at all.

Odds are your problem is caused by 1 file which actually is 0 bytes/empty or which is so insanely large that it won't fit into your hosting enviroment causing it to no be uploaded and marked as a 0byte file.

Check the files you want to upload, find the oversized or zero byte one and remove that one, then try again.
if you can't find it, try again and check your server log. it might indicate which file is causing the error.
TheRealSean replied on at Permalink Reply
TheRealSean
Thanks for your reply,

The problem is more for the client, as they will be uploading the images, and I would rather not provide FTP access

I have tried various, files thinking that the file size may be the case(0bytes), but all the files are ok and work fine. I have tried various folders, and files

I am having to upload using the incoming folder at the moment which works but means I have to do a lot of shifting with files on the server. I am dealing with various galleries and this involves moving files into the incoming folder uploading, deleting, move files back then rinse repeat.

I have roughly 1000+ images more to do, so would prefer to be able to use the multiple upload window. To keep the file structure intact.
Brainakazariua replied on at Permalink Reply
Brainakazariua
Did you check the server log after you got the error?
It might give you a better idea on where to look.

It might be because you try to upload too many images which causes your tmp folder on the server to be to small for it or some other error. You can try it with a smaller batch of images.
It can also be a certain image which is too big.

I see your point on not wanting to grant them FTP access to the entire enviroment, you might ofcourse create a second FTP account and lock it to the /files/incoming folder so they can only add the files to that folder and then use the incoming folder upload under the filemanger.
TheRealSean replied on at Permalink Reply
TheRealSean
I got no log on the server, I don't think it was getting to any stage where it was failing on the server end, I think this is purely C5.

I did also attempt to upload only two files weighing only 5kb each, and still had the same result?

I think I have found the problem, and I think it may possibly be a bug?. The files I am attempting to upload are on a network drive, and although mapped to a drive, it would appear that the images are unable to be loaded or are using the //server/folder/files instead of the path H://folder/files

I don't know without hacking about in the core and attempting to debug it to see what is actually being passed through?.

But my assumption is that C5 is attempting to open files, that it cannot find and therefore, passes through a zero byte file? displaying the error.

I can upload once copied to a local drive on my computer.

Its seems weird though as this is the first site in which this problem has occurred.

Ill check some of my older sites that have been updated and see if they suffer from the same problem now?

Thank you again for your help, its really appreciated
Sean
Brainakazariua replied on at Permalink Reply
Brainakazariua
I have just tested this on my own site which I have a freshly installed concrete5 5.4.1.1 on and encountered no problems (I tested a few different network drives) so it seems that the problem might be on that one site only indicating that something actually is incorrect on that site, either in the database, the permissions or one of the files.
TheRealSean replied on at Permalink Reply
TheRealSean
I too am finding no other problems with any of my other sites, :(

This is the only site I have though that I have running on a subdomain so its possible my configuration files are incorrect, or that Plesk has safe mode turned on for subdomains?.

I can see no problems with the permissions, (not to say there are none) or nothing that stands out from my other sites?

I will have to do some more digging.
Brainakazariua replied on at Permalink Reply
Brainakazariua
Well, you can test that by putting this site on a regular (test) domain instead of a subdomain and see if you still get the problems.

that way you can determine if it is a site problem or a server problem.
TheRealSean replied on at Permalink Reply
TheRealSean
It was only on a subdomain for development, I decided to try a different style of development this time, (wish I hadn't now)

Also attempting to Alter the Memory Limit or Time Limit are failing.

So it seems much more likely now its running in Safe Mode, I'll move it to a new site to try that. Fingers Crossed
Brainakazariua replied on at Permalink Reply
Brainakazariua
Goodluck. Let me know how it works out, might come in handy someday when others encounter a problem which is close or identical to yours.
TheRealSean replied on at Permalink Reply
TheRealSean
I have found out that when you create a sub domain from Plesk Safe Mode is turned on by default, this can NOT be turned off, without shell access.

Ie with Putty,

I have been able to turn off Safe Mode. (Thanks to our Host's support team)

You can tell when safe mode is on if you have memory being exhausted, even after using
Within the .htaccess
php_value memory_limit 32M
php_value max_execution_time 90


Or within PHP
set_time_limit(90);
ini_set('memory_limit', '64M');


You can edit the php.ini

But I do not like to increase to those figures Globally
TheRealSean replied on at Permalink Reply
TheRealSean
Ok this would appear to be a problem with our server, I thought I could upload images from the server, or have always been able to but going back to an older site I noticed I could not upload multiple images, again coming up with the same issue.

I can again access, single uploads, and import from the incoming folder but now all multiple uploads from our server address causes this Zero Byte File issue.

I'll continue to look into the root of the problem but it would appear to be something from this end maybe with our server settings, something must have changed in the run up to Christmas for everything just to stop working.