Really strange edit mode problem

Permalink
Hello everyone,

I have provided a YouTube video to help you explain the problem here; I'm not the greatest expalainer!

http://www.youtube.com/watch?v=fS64MnqJNlM...

The problem is with my homepage (every other page is fine). When logged in, I can see the edit bar fine, however intermittently when NOT editing, I can see all the layouts, red dotted lines etc. When I do go into Edit mode, I see the exact same thing but I cannot highlight over my blocks to bring up the context edit menus. It treats my blocks as content outside of Edit mode.

It only occurs on this 1 page, and I have tried looking for any anomalies in my page type for the home page, but it's fine. No CSS clashes I'm aware of. Any help would be very appreciated, as I am in a tight schedule to get this finished :(

Thanks to all responses :D
Tom

View Replies:
paradigmthreads replied on at Permalink Reply
Whoops apologies for the bad music on the video. I wasn't aware I was recording my sound card when creating the screencast. Thanks
whimsmedia replied on at Permalink Reply
whimsmedia
Looks to me like your home page might not be loading completely.
Usually, I am able to edit blocks on a page only after all the javascript has been loaded. Maybe your browser is doing some unwanted caching.

I'd also try to revert to a version without the Vimeo embed just to be sure the embed code isn't doing anything funny. That seems to happen more often than it should.
wagdi replied on at Permalink Reply
wagdi
paradigmthreads replied on at Permalink Reply
Thanks for the help guys. I have tried both of your suggestions however no difference =[ I had rpeviously tried clearing C5 cache, browser cache and working with different browsers but no luck.
I recently updated my Javascript client, do you think this might be the issue?
whimsmedia replied on at Permalink Reply
whimsmedia
I don't know what to say. There's a lot of java weirdness out there that's too difficult or too time-consuming to diagnose properly. I don't mean just in C5, anything using javascript can get affected.

I've spent most of this morning working out why some pages on another CMS were misfiring. It turned out it was an omitted quote in a YouTube embed code. This is why I suggested you try removing the Vimeo thing temporarily. The issue was still fresh on my mind.

Maybe there's something else on that page that's affecting the scripts.
paradigmthreads replied on at Permalink Reply
Now that I think about it, it seems as if this problem started happening around the time I updated Java on my PC. I will look into the issue. Thanks for your help :) If I manage to find the problem I will report back in case this affects anyone else

Tom
ryan replied on at Permalink Reply
ryan
So, a couple things that may be going on here:
- the z-index of the elements on the page are somehow being raised above the divs that the edit block events are tied into

- There may be a javascript error that's preventing the edit block events from firing

I'd put the page in edit mode with a javascript console enabled, then watch for any errors.

If that doesn't help out at all, then I'd disable the "loader" and other javascript items until you find the culprit.

I'd say it's javascript or css related and not related to java on your system

here's some of the ones I'd potentially disable during edit mode:
<!-- JavaScripts -->
<script src="/packages/simplicity/themes/simplicity/js/corners-min.js" type="text/javascript"></script>
<script src="/packages/simplicity/themes/simplicity/js/preloader.min.js" type="text/javascript"></script>
<script src="/packages/simplicity/themes/simplicity/js/jquery.tipsy.js" type="text/javascript"></script>
<script src="/packages/simplicity/themes/simplicity/js/viva.js" type="text/javascript"></script>
paradigmthreads replied on at Permalink Reply
Hey Ryan,

Thanks for your reply. There seems to be a TON of Z-index settings in just the core CSS files in Concrete5. Any idea of the div handles I need to be checking?

I get 1 error in a JS console, which is "node is null" which points to a script I'm running in the header. This script is a rewards / badges system called PunchTab. I have disabled this script, and I now receive a new error called "href is undefined" which is pointing to a Wordpress plugin I use. Could this be an issue?

href is undefined
if (href.indexOf ("wp-content") == -1) {


This plugin works fine though, so I'm not sure what it could be referring to.
I have disabled the other JS plugins both in Firebug and on the server but it hasn't had an effect.

It could still be a CSS z-index issue but to be honest I have no idea where to start, and I haven't installed anything new since the problem started, so I'm a bit lost :/ any further advice would be very appreciated.

Tom