Content Block (Redactor) can't save? (AJAX Error?)

I have a website for a client which I have been working on and off for the last year and a half and today I get an email saying they cannot save any text typed into the content editor block and each time they try, they get an error message that spouts gibberish.

I asked them to copy paste the entire error to me using the inspector tool or similar and what I got back is quite odd.

It seems that when the editor tries to save anything it just lists the error as all the content from the index page. The error is literately the mark-up from the index page.

I did some research and I found this page
however disabling pretty URLs didn't help as the error persists.

The version of Concrete5 I'm running is

If anyone has any ideas it would be great as this is quite a big problem because currently my client cannot add any pages to their site.

So it looks like this is not just redactor.. I created my own block with CKEditor and on submit it receives the same gibberish error. It worked on local testing so now I think something has happened to the webserver.

Edit 2:
Updating to solved my problem.

View Replies:
thePenrod replied on at Permalink Reply
I'm using the latest update and I'm unable to edit content blocks in site-wide areas (header and footer). And only some of the time can I edit content blocks in a given page.

I can delete blocks but when I go to save edits the toolbar just disappears and I have to reload the page to do anything.

I'm not sure if this is related but your issue was the closest thing I found on the forum. I'll just follow any replies.