Renaming canonical URLs

I am trying to rename a canonical URL and although I am saving the change, when I go back in and view the properties, the page name remains the same.

Two versions of the page originally existed. Accidentally the duplicate ( used to add content to. I then deleted the original page ( and have tried to rename "news1" to "news". The system is not saving the change.

Any ideas on how I can rename the canonical url?


View Replies:
s2d replied on at Permalink Reply
From the Dashboard --> Sitewide Settings --> Debug --> click the big button that says "Clear Cache".
digievo replied on at Permalink Reply
Thanks Kate,

I tried that but it made no difference.

I then thought that it might be because the page has some child pages linked to it.

As a test I created a test page, then created another test page. The first page was index.php/test and the second I also named test. C5 correctly named the second test1 due to the fact that a "test" page already existed.

I then deleted "test" and left the "test1" page. I then cleared the cache and tried renaming "test1" to "test". There were no errors and the change appears to have change but when I view properties the page is still named "test1".

I also created a child page to "test1", deleted the child, cleared the cache and then tried to rename the page. Again no luck.

It looks like Concrete5 will not allow me to rename the canonical entry on a page.

Has anyone else experienced this issue?

Any other assistance would be greatly appreciated.

garyam replied on at Permalink Reply
I am also having these issues -- I created a blog page after buying Simple Blog. I thought I screwed it up so I created a second Blog page, deleted the original and now I cannot rename blog1 to blog. "blog" is somehow stored somewhere as a reserved Canonical URL even though the original page was deleted.

Maybe there's a way to clear that in the database -- clear the reserved canonical URL... clearing the cache does not do it.

Any ideas?
CapaSite replied on at Permalink Reply
You see previous version of your page in PagePaths Table
garyam replied on at Permalink Reply
I didn't see CapaSite's quesiton till just now... I checked PagePaths and yes, "/blog" is indeed in that table and it has a value of 0 for ppIsCanonical.

What can I do with that to fix this issue for me and others here so we can make that path be available again for new pages... thanks!
aghouseh replied on at Permalink Reply
Unfortunately for you and fortunately for myself, I did not have an entry at /music, so I just renamed the /music1 entry in PagePaths to /music and it seems to be working fine. What I did do before that was go directly to the /music page and do Edit Page, then Delete the Page from the C5 web interface. Hope that solves it for you - good luck!
aghouseh replied on at Permalink Reply
I am having the exact same issues. I have a page named "Music" that is stored as "/music1" but I cannot rename it to "/music". I checked the sitemap to confirm there is no duplicate, and the change shows as being saved, but no go.

Anyone else able to solve this guy?
Jamesr replied on at Permalink Reply
I'm experiencing the exact same problem, I'm stuck with 'About1' and can not change back to 'About'.

Is there any way this reference to 'About' can be deleted from the database?
aghouseh replied on at Permalink Reply
I was able to fix this by making sure that there was no existing page by checking the site map, then going into the C5 PagePaths database and changing the entry manually from music1 to music (about1 to about, in your case).
Jamesr replied on at Permalink Reply
Thanks Aghouseh, how do I access the PagePaths database?
Jamesr replied on at Permalink Reply
Never mind - got in through PHPmyadmin! Seems to have done the trick - cheers!
waroly replied on at Permalink Reply
I have changed the canonical URL through the pagepaths database and the navigation seems to be working correctly. I also deleted some pagepaths for long ago trashed and deleted pages that still showed up in the database that had zeros next to them. I saw elsewhere in these Forums that this was OK to do.

Now my site has slowed down significantly and I am getting the following error in the Safari Error Console:

Error: Error calling method on NPObject.
(anonymous function)

This error does not show up in Firefox Firebug.

Was it a mistake to modify the database in this way?