RSS displayer block not updating

Permalink
i'm trying to take a feed from tumblr and its not updating until i go in and edit it. i did change the interval to 60 seconds but still doesnt work.

on 5.4.2 by the way.

View Replies:
MattWaters replied on at Permalink Reply
MattWaters
The solution I've found that seems to work is changing the cache time in the SimplePie library. Copy concrete/libraries/3rdparty/simplepie.php up to the proper override directory: (your site root)/libraries/3rdparty/simplepie.php. Open the new copy in a plain text editor and search for this value:

var $cache_duration = 3600;


This is the number of seconds it waits before refreshing. Change this to something like 120 (two minutes). Don't get too aggressive with it or you'll get your site banned from the feed, I guess.

Try that and let me know how it works. Lots of thanks to ScottC for this fix.
czestate replied on at Permalink Reply
This did not work for me. I didn't think 120 would if 3600 didn't. Any other suggestions?
noonchyo replied on at Permalink Reply
Didn't work for me either. I tried turning all caching off, clearing the cache. Will let you know tomorrow when my RSS feed updates.
noonchyo replied on at Permalink Reply
Talked to a co-worker...says he just noticed his RSS block has not been updating since he upgraded a year ago. Said it used to work fine under 5.4.1.1

Perhaps this is an unreported bug?

http://www.concrete5.org/index.php?cID=229446...
robert1984 replied on at Permalink Reply
Hi,

I have cleared the cache and disabled the basic cache but when it comes to updating the (var $cache_duration = 3600;) the document opens in notepad and when I save it it doesn't update to the simplepie.

any ideas as to how i can get round this??

thanks

Robert
robert1984 replied on at Permalink Reply
think i have found it...silly me!
czestate replied on at Permalink Reply
I don't know but I wish they'd address this. There a lot of people complaining about it. There's no point in having a "news" of an RSS feed if it never updates.
12345j replied on at Permalink Reply
12345j
pretty sure if you go into root/concrete5/blocks/rss_displayer/controller.php and copy to root/blocks/rss_displayer/controller.php and delete this stuff
protected $btCacheBlockRecord = true;
      protected $btCacheBlockOutput = true;
      protected $btCacheBlockOutputOnPost = true;
      protected $btCacheBlockOutputForRegisteredUsers = true;
it'll work
noonchyo replied on at Permalink Reply
Thanks for the tip! This appears to have solved the problem...however, I am fortunate to have root access to my server. Might not help everyone. :-)
12345j replied on at Permalink Reply
12345j
you don't need root, just using that as the directory that c5 is installed in.
akopke replied on at Permalink Reply
Yes! Thanks so much for the help, only took a minute to fix.
kettc replied on at Permalink Reply
This fix works, but had a negative side-effect for me. It removed the formatting of the RSS Displayer block. Instead of bold Titles and nicely-spaced Summaries, it all became plain text. When I removed the controller.php changes, the block got pretty again! This may be a function of my template, css, etc. but still...

Here is another fix that works for me:
http://www.concrete5.org/index.php?cID=92552...

Thanks!
TheRealSean replied on at Permalink Reply
TheRealSean
Removing the caching info should not muck up your style, this suggests you took to much out.
webicine replied on at Permalink Reply
webicine
Thanks so much! This solution worked for me too.