Site Content Missing

Permalink
Hi there.

Suddenly today, a lot of content is missing from multiple pages of my website. I checked Previous page versions, and there is no record of the content ever existing.

As well, on pages which are experiencing this missing content, when I am logged in to C5, my Administrator c5 toolbar at the top of the screen is just a blank white space, but on unnafected pages, the bar is working and intact.

I have no idea why this is happening all of a sudden, I haven't messed with anything recently

I contacted my WebHost, and they assured me there was no data loss on the server.

I am going to proceed by remaking my homepage from scratch, and then monitor to see if the issue affects that page again in the future. As for the other affected pages, I am going to wait a bit, and see if I get any solutions posted here, before remaking my entire 54 page website O_o

UPDATE: Since rebuilding all the affected pages, each day since, things have started to dissapear from pages again, usually at the rate of 1-4 Blocks per day. They also dissapear from the clipboard, and previous page versions.

1 Attachment

severas
View Replies:
severas replied on at Permalink Reply 1 Attachment
severas
attached is a screenshot
phil7 replied on at Permalink Reply
Concrete 5 is one of the worst software I 've seen. Before deciding to work with COncrete 5 I had an overview over Joomla, Drupal and COncrete 5. I made the worst chise by going on Concrete 5 as at that time I was impressed with what it can do. But is far form beeing a solid software. I got today same problem as you: After saving an edited block the entire block dissapear. When cheking the versions there was no evidence I ever edited a block. It happened 5 times today. So I edited a large content block and saved formtime to time. Save page and re edit. And when adding more text and saving the block the entire block disspapeared.
Now I understand why last day page ocntents were aslo erased.
Sorry but this is not a professional software but a toy for html programmers.....I regret I wasted so many weeks trying to develop a web site with this crap...
exchangecore replied on at Permalink Reply
exchangecore
Concrete5 is far from a "toy from HTML programmers". I have a hunch that this is related to a Concrete5 update that may have broken some custom elements of the theme. Could you provide a site URL for some of us to take a closer look at it?
mnakalay replied on at Permalink Reply
mnakalay
I agree with severas, if some areas changed names for instance, content will disappear but it will disappear from view only, not be deleted.

If the missing content was content blocks for instance, you chould go to your database and look for the table btContentLocal and see if your missing content is still there, that would rule out a "C5 is deleting my data" type scenario.

@phil7 very sorry you feel so bad about your experience with C5. I can't help to notice that since you registered a little more than a month ago you barely communicated on any issue you were having.
One of C5's strength is its extremely helpful community. I don't mean every problem gets solved or even sometimes addressed, but it does, more often than not, and it's always extremely thorough. And keep in mind it's help coming from people who would otherwise charge anywhere between $35 and $120 per hour. Here they're doing it for free.
If you don't take advantage of this possibility, this community, you are missing out on one of C5's main benefits.
So may I suggest you start a new thread and try to get some help?

Good luck to all
phil7 replied on at Permalink Reply
HI


I have to say I am very impressed by you guys. I admit I was a little bit too ironic but it was 2.00 Am in the morning and I was out of my mind when I noticed that fro the thrid time in a row a newly edited block on this pagehttp://filkon.ro/concrete/index.php/produse/consumabile/cerneala/... dissappear after clicking on the save block. It was a content block with text and images. After editing the block ( adding text and images) all went out. Couldnt belive it. As it was late I figured out it was my mistake so I started all over again. It was a lot of text ( something like an A4 page adn 3 images). Took a while to write it again.
Then on some other page I noticed newlly added pictures in two different blocks ( content blocks again) dissapeared.
I got frustrated and realised that I cannto continue with the software if my work is randomly out of the web site.

I watched in the month I started to leanr Concrete about all videos. The reaosn I did not posted anything yet was it because I was learning and did not faced any issues.

So I returned to Drupal. Drupal has some advantages and of coure some disatvantages. What I like in concrete 5 is that over Drupal it has automatic ( or easy) way of installin themes and modules. While in Durpal is far complicated ( I mean I have to unzip them i certain web folders). But what I like more on Drupal is that you can promote some informations on the first page easily whiel with Concrete 5 is somehow more strange ( even if I installed a module for this).

But my current problem is this random erase of content blocks form the page. I fanyone have an idea I would be obliged

Once again I am very impressed with your kind reaction to my mean frustration !!
mnakalay replied on at Permalink Reply
mnakalay
It's ok don't worry about it.

So as a first step let's go through the obvious:
1- after saving your block did you click on "publish my edits" that you can see when you hover the edit button on the left on the toolbar?
2- when hovering the edit button, in the menu that appears, can you click on "Versions" and check the list of your versions. The one in bold is the one currently active. If it's not the top one in the list than it means you have not approved your modifications. By clicking on a version, you can have a look at it to see if it's what you want. If you want to activate a version, check the box next to it and click on the little thumbs up icon. Then exit edit mode and maybe reload your page and see if your content is back there.

If none of this is helping, please feel free to come back and we'll try something else.
phil7 replied on at Permalink Reply
THank you MNAKALAY!

Yes I knwo all these. You are right

But my problem si stranger:

SO you got the content editor window ( the on ethat resembles with an word editor).
After compelting the text and adding pictures in this window I clicked on save button. When the window was closed the block disspapaered ( the editing wa gone).

So if I went to press publish my changes ( or so) obviously there were no changes and the saving was identicla with the previous state.

I tried aslo the version checinks. I could see there 5 verisons and all showed the same stuff: no last edited and saved content block.

SO the problem looks like a bug: After adding a content block of a certain text lenght ( this is what I am thinking of) you cannot save it and in consequenvence I cannt publish anything new.
This is the problme


On other web page within this same website I could save a block containing two pictures and some text ( two lines) . I saw it after saving. I publish edits. Everythinhg all right. Next day was gone.
mnakalay replied on at Permalink Reply
mnakalay
Hi again, actually there is something wrong with your website. I don't know if it's the cause of your problem or not but it might.

It seems your theme is loading an old version of jquery (1.4.1) which is very outdated considering your version of C5 uses jquery 1.7.2.

The editing interface relies 100% on jquery so that might be the problem.

Typically, your theme will have a header probably called header.php and probably in a folder called elements inside the theme folder. in your case it's in packages/cannonf700_innovation/themes/innovation/

In that header.php file you should have a line that says
<?php   Loader::element('header_required'); ?>


It is important that you do not load any javascript or css files before that line so move any css or javascript below that line.

Than, delete or comment out the line that loads jquery 1.4.2.

After that do some tests and see if you still having that problem.
phil7 replied on at Permalink Reply
Many Thanks MNAKALAY! I will try this. Hopefully there is a way to update that jquery. The template I got it from the concrete website.
mnakalay replied on at Permalink Reply
mnakalay
don't try to update it just make sure only C5 jquery is loaded so it's the proper version and there is no conflict.
Good luck
denniss112 replied on at Permalink Reply
I fixed it by putting in a globalarea instead off a normal area.