Source code editor in 8.2 does not save the plain text

Permalink
Hi there,

just to notice: if you edit a block ... then click to [source] to open the sourceode editor. The content won't be saved as "plain text" anymore. This behavior has changed with the new editor.

Example:
If you type
[something in "quotes"]

and save it ... then you get
[something in & quot; quotes & quot;]


In my page templates I handle this behaviuor of the change from " to & quot; in the meanwhile. But this is more a hack :-/

Does anybody have a list of rules for made replacements in source mode?
Is there a trick to save plain text as entered?

regards,
Axel

1 Attachment

axelhahn
View Replies:
stewblack23 replied on at Permalink Reply
stewblack23
Go to System & Settings > Rich Text Editor and check the "Paste As Plain Text" box. Then click save. That should take care of your problems. You might also want to check the "Paste from Word" box as well if you have a lot of content that you past from word processing programs.
axelhahn replied on at Permalink Reply
axelhahn
Hi,
I tried your hint :-) That option enables an additional button in the editor. Clicking on this paste icon you get a small dialog to enter text that will be added in the current block. But it is the same: If you click on [source] on the top left the " is changed to & quot;

It seems that a " will be kept inside < ... > and outside it will be converted.
This is not bad for the most people ... just different to the editor before.

(Maybe I close this topic??)
Axel
stewblack23 replied on at Permalink Reply
stewblack23
After playing with it for a while. I think C5 does this since php uses quotes to open and close variables and other parts of the code. And maybe C5 might get confused with the quotes when in plain text. Sorry my idea did not work.