Subfolder installation problems

Permalink
Because I installed C5 on an existing site, the installer insisted on installing it in a subfolder, so I chose ~/c5. The home page seems to work okay, but when I try to create the About, Blog, and Search pages, by clicking on them the way I did for an installation in the top folder of a site, the link does not go to the pre-created pages for editing, but instead goes to the index.shtml file for the existing site in the top folder, and when I try to add a page, give it the name of one of those pre-defined links, it doesn't find it, so I have to enter the node number URL to get back to it, with no obvious way to make the links on the Nav bar go to them.

Yes, I have checked that c5 is defined in site.php and .htaccess. What am I missing to enable normal page creation and editing in a subfolder tree.

I decided that although these problems are related to a way C5 was installed, they seem to be a kind of editing problem, so posted here. The site ishttp://constitution.org/c5 . Eventually we plan to put a redirect page in place of the current top-level index.shtml page, taking visitors to the /c5/index.php file.

JonRoland
View Replies:
nteaviation replied on at Permalink Reply
nteaviation
Are you using pretty URL's? If you are using apache check the .conf configuration files (probably pertaining to the webroot or /home/* directories). Is there anything interesting in your server's error logs?
JonRoland replied on at Permalink Reply
JonRoland
Yes, I set up "pretty URLs". But this is a shared host (dreamhost.com), so I don't have access to much of what Apache does.
JonRoland replied on at Permalink Reply
JonRoland
Tried disabling pretty URLs and now the links go to the right pages, but I shouldn't have to do that. There are advantages to using pretty URLs.
nteaviation replied on at Permalink Reply
nteaviation
What do you have in your .htaccess? Are the permissions on your .htaccess file set readable by all? Maybe another "Dreamhost" user can help out?
JonRoland replied on at Permalink Reply
JonRoland
I modified .htaccess and request.php as I discussed inhttp://www.concrete5.org/community/forums/usage/linking-additional-... It is not a permissions problem.
nteaviation replied on at Permalink Reply
nteaviation
You said you are running in the "subfolder" of c5. If that is the case you should have a "RewriteBase" statement in your .htaccess My .htattess using the subflolder "it" looks like this.
RewriteEngine On
      RewriteBase /it/
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule ^(.*)$ index.php/$1 [L]
JonRoland replied on at Permalink Reply
JonRoland
My one .htaccess file in the c5 folder contains:
RewriteEngine On
      RewriteBase /c5/
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule ^(.*)$ index.php/$1 [L]


However, it looks like pretty URLs may be enabled even thought I unchecked the box for it in Dashboard | Sitewide Settings | Linking , perhaps as the result of the edits to the .htaccess and request.php files. Checking the box seems to cause the problem.
nteaviation replied on at Permalink Reply
nteaviation
This may be a dumb question, but you do have two .htaccess files, one in your web root and one in the /C5 sub directory? Just checking :)
nteaviation replied on at Permalink Reply
nteaviation
You may want to turn caching off in C5 until this is resolved. Does clearing your cache (both browser and concrete5) make any difference?
JonRoland replied on at Permalink Reply
JonRoland
Clearing cache makes no difference.
nteaviation replied on at Permalink Reply
nteaviation
JonRoland replied on at Permalink Reply
JonRoland
Yes nteaviation I saw those, even posted replies.
conciseusa replied on at Permalink Reply
When I put this in the .htaccess of my root, things started working:


Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !^/condir
RewriteRule ^(.*)$ condir/$1 [L]


After reading about 10 Concrete threads and getting nowhere, I opened one about the same issue with Drupal and found the solution above.
sager replied on at Permalink Reply
I'd like to confirm this solution (Options +FollowSymLinks) - easily fixed my subdomain redirection problem. Probably my server (rented space) does not have that line in their httpd.conf file.