Unable to copy file to storage directory.

Permalink
Hi,

I'm getting this error when trying to multi-upload images in my dashboard:

"Unable to copy file to storage directory. Please check permissions on your upload directory and ensure they can be written to by your web server."

If I want to upload (let's say) 20 images, 5 of them will be uploaded, the rest of them get this error.

It also happens when I upload images individually. Most of the time it works correct, but once in 5 times I get the error shown above.

/files is CHMODded to 777
php safe mode is OFF.

Can anyone help me?

- Tom

PS. I've recently moved this website from another domain. I installed a fresh copy of Concrete5, and then just overwritten the database with a backup of the 'test'-database and overwritten everything from the new installation, EXCEPT for the 'config' directory.

View Replies: View Best Answer
adajad replied on at Permalink Reply
adajad
It could be a php.ini issue. Take a look at your post_max_size setting and also max_file_uploads setting.
Tommiiee replied on at Permalink Reply
The files I'm trying to upload are max. 5KB..
adajad replied on at Permalink Reply
adajad
max_file_uploads determines the maximum number of files you can upload via a single request, and if it's set to 5 you can only upload 5 files each time.

Unless that is the problem, I have no further clue...
Tommiiee replied on at Permalink Reply
I just checked.

Max_upload is 32M
Max_file_upload is 20.

Since the problem often occurs with the second file (and on) with the multiple-upload, this isn't the problem :(
Tommiiee replied on at Permalink Best Answer Reply
Found the solution.

My /folder directory was CHMODded 777 by DirectAdmin, but not recursively. I re-CHMODded /files to 777 and checked the 'recursive' checkbox.

Everything's working fine now.